[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: update caused java breakage



I think yesterday's openjdk update may have broken Java somehow....the
Arduino-0013 IDE doesn't function after being drawn on the screen. The
IDE window will either go white, or you can maximize it or minimize it
but not close the window or do anything else with it. I saw the
reference to XINERAMA that another person responding to Brian's post
write about, abnd I looked over the archlinux thread, but I'm not quite
sure what to do. I have Sun's Java JDK installed and I wonder if the
openjdk update wiped out something needed by the Sun JDK.

Bob


brian wrote:
> Since allowing some updates a couple days ago, I can no longer run
> jEdit. It looks like it's something to do with X11 or GTK but that's
> about as much as I can figure out.
>
> When I try starting the app, it hangs with a white screen. The
> ~/.jedit/activity.log shows:
>
> -- snip --
> java.version=1.5.0_14
> java.vm.version=1.5.0_14-b03
> java.runtime.version=1.5.0_14-b03
> java.vendor=Sun Microsystems Inc.
> java.compiler=null
> os.name=Linux
> os.version=2.6.27.19-170.2.35.fc10.i686
> os.arch=i386
> user.home=/home/bde
> java.home=/usr/lib/jvm/java-1.5.0-sun-1.5.0.14/jre
> java.class.path=/home/bde/jedit/4.3pre12/jedit.jar
> An error occurred while connecting to the jEdit server instance.
> This probably means that jEdit crashed and/or exited abnormally
> the last time it was run.
> If you don't know what this means, don't worry.
> java.net.ConnectException: Connection refused
>  at java.net.PlainSocketImpl.socketConnect(Native Method)
>  at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
>  at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
>  at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
>  at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
>  at java.net.Socket.connect(Socket.java:520)
>  at java.net.Socket.connect(Socket.java:470)
>  at java.net.Socket.<init>(Socket.java:367)
>  at java.net.Socket.<init>(Socket.java:209)
>  at org.gjt.sp.jedit.jEdit.main(jEdit.java:247)
> -- snip --
>
> I've tried starting it from a terminal with the -noserver switch but
> it still hangs, and I get a backtrace:
>
> -- snip --
> $ jedit -noserver
> Locking assertion failure.  Backtrace:
> #0 /usr/lib/libxcb-xlib.so.0 [0xdfc767]
> #1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_unlock+0x31) [0xdfc831]
> #2 /usr/lib/libX11.so.6(_XReply+0x254) [0x24bf54]
> #3 /usr/lib/jvm/java-1.5.0-sun-1.5.0.14/jre/lib/i386/xawt/libmawt.so
> [0xa33dad7e]
> #4 /usr/lib/jvm/java-1.5.0-sun-1.5.0.14/jre/lib/i386/xawt/libmawt.so
> [0xa33c4d47]
> #5 /usr/lib/jvm/java-1.5.0-sun-1.5.0.14/jre/lib/i386/xawt/libmawt.so
> [0xa33c4ec3]
> #6
> /usr/lib/jvm/java-1.5.0-sun-1.5.0.14/jre/lib/i386/xawt/libmawt.so(Java_sun_awt_X11GraphicsEnvironment_initDisplay+0x26)
> [0xa33c5106]
> #7 [0xb4030bfa]
> #8 [0xb402ab3b]
> #9 [0xb402ab3b]
> #10 [0xb4028219]
> #11 /usr/lib/jvm/java-1.5.0-sun-1.5.0.14/jre/lib/i386/client/libjvm.so
> [0xb7a052bc]
> #12 /usr/lib/jvm/java-1.5.0-sun-1.5.0.14/jre/lib/i386/client/libjvm.so
> [0xb7b19f98]
> #13 /usr/lib/jvm/java-1.5.0-sun-1.5.0.14/jre/lib/i386/client/libjvm.so
> [0xb7a050ef]
> #14
> /usr/lib/jvm/java-1.5.0-sun-1.5.0.14/jre/lib/i386/client/libjvm.so(JVM_DoPrivileged+0x32d)
> [0xb7a62b9d]
> #15
> /usr/lib/jvm/java-1.5.0-sun-1.5.0.14/jre/lib/i386/libjava.so(Java_java_security_AccessController_doPrivileged__Ljava_security_PrivilegedAction_2+0x3d)
> [0xb784c30d]
> #16 [0xb40304ab]
> #17 [0xb402aa64]
> #18 [0xb4028219]
> #19 /usr/lib/jvm/java-1.5.0-sun-1.5.0.14/jre/lib/i386/client/libjvm.so
> [0xb7a052bc]
> Locking assertion failure.  Backtrace:
> #0 /usr/lib/libxcb-xlib.so.0 [0xdfc767]
> #1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0xdfc90e]
> #2 /usr/lib/libX11.so.6 [0x24b0e9]
> #3 /usr/lib/libX11.so.6(XGetVisualInfo+0x26) [0x241216]
> #4 /usr/lib/jvm/java-1.5.0-sun-1.5.0.14/jre/lib/i386/xawt/libmawt.so
> [0xa33c4089]
> #5 /usr/lib/jvm/java-1.5.0-sun-1.5.0.14/jre/lib/i386/xawt/libmawt.so
> [0xa33c42d3]
> #6 /usr/lib/jvm/java-1.5.0-sun-1.5.0.14/jre/lib/i386/xawt/libmawt.so
> [0xa33c4f71]
> #7
> /usr/lib/jvm/java-1.5.0-sun-1.5.0.14/jre/lib/i386/xawt/libmawt.so(Java_sun_awt_X11GraphicsEnvironment_initDisplay+0x26)
> [0xa33c5106]
> #8 [0xb4030bfa]
> #9 [0xb402ab3b]
> #10 [0xb402ab3b]
> #11 [0xb4028219]
> #12 /usr/lib/jvm/java-1.5.0-sun-1.5.0.14/jre/lib/i386/client/libjvm.so
> [0xb7a052bc]
> #13 /usr/lib/jvm/java-1.5.0-sun-1.5.0.14/jre/lib/i386/client/libjvm.so
> [0xb7b19f98]
> #14 /usr/lib/jvm/java-1.5.0-sun-1.5.0.14/jre/lib/i386/client/libjvm.so
> [0xb7a050ef]
> #15
> /usr/lib/jvm/java-1.5.0-sun-1.5.0.14/jre/lib/i386/client/libjvm.so(JVM_DoPrivileged+0x32d)
> [0xb7a62b9d]
> #16
> /usr/lib/jvm/java-1.5.0-sun-1.5.0.14/jre/lib/i386/libjava.so(Java_java_security_AccessController_doPrivileged__Ljava_security_PrivilegedAction_2+0x3d)
> [0xb784c30d]
> #17 [0xb40304ab]
> #18 [0xb402aa64]
> #19 [0xb4028219]
> -- snip --
>
> I'm really unsure of what to make of that. The security stuff made me
> wonder about SELinux but that's disabled.
>
> I've also tried moving ~/.jedit but encounter the same hangup.
> Attempts to install 4.3pre16 or the older 4.2 result in pretty much
> the same backtrace as above.
>
> While trying to debug this, I also realised that I don't have openJDK
> installed, which seems really odd. I thought that was the default for
> Fedora 10.
>
> $ rpm -qa | grep java
> glib-java-0.2.6-13.fc10.i386
> java-1.5.0-sun-jdbc-1.5.0.14-1jpp.i586
> java-1.5.0-sun-plugin-1.5.0.14-1jpp.i586
> java-1.5.0-sun-fonts-1.5.0.14-1jpp.i586
> java-1.5.0-gcj-1.5.0.0-23.fc10.i386
> java-1.5.0-sun-1.5.0.14-1jpp.i586
> java_cup-0.10k-1.i386
> java-1.5.0-sun-src-1.5.0.14-1jpp.i586
> java-1.5.0-sun-alsa-1.5.0.14-1jpp.i586
> java-1.5.0-sun-devel-1.5.0.14-1jpp.i586
>
> Anyone think it's worth installing openJDK to see if it deals better?
>
> These are the updated packages:
>
> selinux-policy-3.5.13-49.fc10.noarch
> selinux-policy-targeted-3.5.13-49.fc10.noarch
> libX11-1.1.5-1.fc10.i386
> libX11-devel-1.1.5-1.fc10.i386
> xorg-x11-drv-vesa-2.2.0-3.fc10.i386
> gtk2-2.14.7-7.fc10.i386
> lcms-1.18-1.fc10.i386
> lcms-libs-1.18-1.fc10.i386
> postgresql-libs-8.3.7-1.fc10.i386
> postgresql-plperl-8.3.7-1.fc10.i386
> postgresql-plpython-8.3.7-1.fc10.i386
> postgresql-8.3.7-1.fc10.i386
> postgresql-server-8.3.7-1.fc10.i386
>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]