[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: update caused java breakage



Roberto Ragusa wrote:
brian wrote:
Since allowing some updates a couple days ago, I can no longer run
jEdit. It looks like it's something to do with X11 or GTK but that's
about as much as I can figure out.
Locking assertion failure.  Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xdfc767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_unlock+0x31) [0xdfc831]

I remember something similar happened time ago, sed command to
disable XINERAMA...

Have a look at this:
  http://bugs.archlinux.org/task/8521
>
>
These are the updated packages:

selinux-policy-3.5.13-49.fc10.noarch
selinux-policy-targeted-3.5.13-49.fc10.noarch
libX11-1.1.5-1.fc10.i386

I guess it's libX11 which is enforcing locking rules
which are violated by the old jpp 1.5.0 you are using.

Try this
  export LIBXCB_ALLOW_SLOPPY_LOCK=1
or patch the libmawt.so using sed
or, yes, change the JVM to something less buggy.

Best regards.


Thanks, Roberto. I guess I was googling the wrong things. It certainly appears to be the same problem. Strange that it still exists.

I read through that and this page, also:
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6532373

I tried both the export and:

sed -i 's/XINERAMA/FAKEEXTN/g' /usr/lib/jvm/java-1.5.0-sun-1.5.0.14/jre/lib/i386/xawt/libmawt.so

Unfortunately, neither fix worked for me. But, at least I have a better idea what the problem is.

Something else that I'm confused about is that I used alternatives --config java to set the jvm to use gcj but, when I try to start jEdit, I see that it's still being run by java-1.5.0-sun-1.5.0.14 for some reason.

Also, is jPackage of no use for Fedora 10? There don't seem to be any repos available for 10. Or, am I missing something important?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]