[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: boot problem with software raid1



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Le 25/03/2009 21:21, Roberto Ragusa a écrit :
> Sam Varshavchik wrote:
>> François Patte writes:
>>
>>> Sometimes, randomly, the system cannot boot and stops after enabling
>>> udev with this message:
>>>
>>> checking file system
>>>
>>> /dev/md0 Resize inode not valid
> 
>> Try dropping, then re-adding one of the drives in the RAID, then wait
>> until it syncs back up, then run fsck again.
> 
> But this could mean copying the bad disk to the good one.
> Remove one of the drive, boot the system, run fsck.
> If everything appears to be OK, readd the second drive and let it sync.
> If not, poweroff, remove the drive, replug only the second one.
> Try fsck on this one and see the result.

Thanks for answering. I still have many problems!

1- "normal" boot displaying this error: "/dev/md0 Resize inode not valid".

system message says: type Ctrl d (-->reboot) and sometimes the boot is
almost normal with an automatic fsck on /dev/md0. Sometimes system won't
reboot.

The alternative to Ctrl d is "enter root password". In that case, I
can't do anything because the keyboard is upset: characters are
displayed on the screen only 2 by 2 and in the wrong order: if I type
"fs", I get on the screen: "sf" and only after typing the "s". So to get
the sequence: "fsck /dev/md0" I have to type:

sfkc d/vem/0d

and... the answer is: "fk unknown command"

2- I tried the rescue disk. The system is mounted on /mnt/sysimage and,
after chroot, if I try "fsck /dev/md0" I am warned not to do such a
thing on a mounted system....

I can't unmount /dev/md0 because it is my root partition....

3- I tried the rescue disk without mounting the system and tried fsck on
/dev/sdb1 (which the first raid disk) the answer:

fsck.mdraid failed: fstab not found.....

Of course the sytem is not mounted....

If I try: "fsck /dev/md0" the device /dev/md0 is unknown...

I don't know how to proceed!

I will try what you recommand above.

> 
> If even in this case you have problems, none of the disks is
> itself "correct" and the problem is just unresolvable.
> Just start copying your data away from this filesystem
> and recreate it from scratch.

I that case I don't know how to proceed: I have 2 raid partitions:

/dev/md0 is the / partition (about 1GB)

/dev/md1 is the "remaining" lvm with logical volume for usr, tmp, var
and home.

How can I re-install only / (i.e. mainly the kernel and config files....)?


Thanks to help me.

Best regards.

- --
François Patte
UFR de mathématiques et informatique
Université Paris Descartes
45, rue des Saints Pères
F-75270 Paris Cedex 06
Tél. +33 (0)1 4286 2145
http://www.math-info.univ-paris5.fr/~patte
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org

iEYEARECAAYFAknLN1MACgkQdE6C2dhV2JUKQACfbJTwcW1EgW/6CiKeoGSs7Twt
MrAAoNT+b7mDJMyF5e6Q/J1VqxD2E5oB
=g4Xa
-----END PGP SIGNATURE-----


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]