[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: RPMs forward compatibility between releases



Mike Burger wrote:
> If/when I need to do something like this, I download the src.rpm, instead,
> and use rpmbuild to build it for the version I'm running.
> 
> This usually suffices until I am ready to perform a full upgrade.

But even that will not work with RPMs from Fedora 11 or (in the future)
newer on Fedora 9 or older. Even the SRPMs have the new checksum format
(SHA256 instead of MD5) which requires at least Fedora 10 with updates to
interpret. (It's possible to manually unpack the SRPM using file-roller or
Krusader though, which bypasses the checksum validations.)

        Kevin Kofler


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]