[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: (no subject)



On Tue, Mar 31, 2009 at 9:21 AM,  <dcooke efn org> wrote:
>
> Does Yum also update the old baseurl's in /etc/yum.repos.d when
> you get the first new one to work?
>
> My Yum keeps looking for core 5.
>
> http://download.fedora.redhat.com/pub/fedora/linux/core/5/i386
> /os/FC10/repodata/repomd.xml: [Errno 14] HTTP Error 404: Date: Tue,
> 31 Mar 2009 01:26:15 GMT
>
> Can someone send a recent baseurl for use?
>
>  in /etc/yum.repos.d, Here's what's listed...
> ]# ls
>
> adobe-linux-i386.repo     fedora-rawhide.repo
> fedora-updates-testing.repo
> dries.repo                fedora.repo          freshrpms.repo
> fedora-core.repo.rpmsave  fedora-updates.repo  macromedia.repo
>
> I will send you any of their contents if needed...or build something
> anew?
>
> Yum wants to point to dries so I copied this one found here on the
> list..
>
> ftp://download.fedora.redhat.com/pub/fedora/linux/releases/10/Fedora
> /i386/os/Packages/fedora-release-*noarch.rpm
>
> copied this one to a repos.d file
> http://download.fedora.redhat.com/pub/fedora/linux/core/10/i386/FC10/repodata/repomd.xml:
> [Errno 14] HTTP Error 404: Date: Tue, 31 Mar 2009 15:39:51 GMT
>
> or
> Cannot open/read repomd.xml file for repository: dries
> failure: repodata/repomd.xml from dries: [Errno 256] No more
> mirrors to try.
> Cannot open/read repomd.xml file for repository: dries
>  repomd.xml broken?
>
> [root boatbuyer yum.repos.d]# yum update
> Options Error: Error parsing 'baseurl': URL must be http, ftp, file
> or https not ""
>  su -c yum --disablerepo=* install libX11-1.1.5-2.fc10.i386.rpm
> libX11-devel-1.1.5-2.fc10.i386.rpm
> su: unrecognized option `--disablerepo=*
>
> # yum --disablerepo=* install
> ftp://download.fedora.redhat.com/pub/fedora/linux/releases/10/Fedora/i386/os/Packages/fedora-release-*noarch.rpmLoading
> "installonlyn" plugin
> Setting up Install Process
> Setting up repositories
> No Repositories Available to Set Up
> Reading repository metadata in from local files
> Parsing package install arguments
> No Match for argument:
> ftp://download.fedora.redhat.com/pub/fedora/linux/releases/10/Fedora/i386/os/Packages/fedora-release-*noarch.rpm
> Nothing to do
>
> I'm copying examples, don't know what I'm doing and not getting
> anywhere..need some..yelp.
>
>
> ?
>
>
> David..

1. Don't use yum to install the package. Try using "rpm -Uvh
ftp://download.fedora.redhat.com/pub/fedora/linux/releases/10/Fedora/i386/os/Packages/fedora-release-10.1.noarch.rpm";

2. Using yum to upgrade versions that far a part is not recommended.
You are better off upgrading via a network install or using a CD/DVD.
However, if you go this route verify that all the .repo files point to
F10 repositories, upgrade yum before installing any other F10
packages.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]