[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: routing problems with f11



Is this really such a strange setup, to route a network over ppp to
the internet?

Has somebody else a similar setup, and can confirm it works for him/her?

Thanks you in advance, Clemens

2009/5/9 Clemens Eisserer <linuxhippy gmail com>:
> Hi,
>
> I have I server which routes a private network to the internet through ppp.
> All I had to do on Fedora-8 was:
>> /sbin/ifconfig eth0 up 192.168.1.1
>> echo 1 > /proc/sys/net/ipv4/ip_forward
>> /sbin/iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE
>
> However with Fedora-11 this doesn't work anymore. Packes simply are
> not forewarded anymore.
> The routing tables look 1:1 the same:
>
> Fedora8:
>> 10.64.64.64     *               255.255.255.255 UH    0      0        0 ppp0
>> 192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
>> default         *               0.0.0.0         U     0      0        0 ppp0
>
> Fedora11:
>> 10.64.64.64     *               255.255.255.255 UH    0      0        0 ppp0
>> 192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
>> default         *               0.0.0.0         U     0      0        0 ppp0
>
> Any idea what the problem could be, or how I can debug that problem.
>
> I already asked at fedora-forums as well as on this list once, but
> nobody had any clue whats going on here :-/
>
> Thank you in advance, Clemens
>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]