[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ssh connects to originating host



On 05/12/2009 11:12:42 AM, Christopher K. Johnson wrote:
> Geoffrey Leach wrote:
> > Two systems A and B, connected via wireless. A and B both have the
> same 
> > /etc/hosts. Connecting from B to A, "ssh A", works fine. However on
> A, 
> > "ssh B" logs me into A. This used to work fine; the only clue I 
> have
> is 
> > that ssh did not like the stored RSA key. I let it fix it, and
> that's 
> > when the trouble started. Rebooting A did not fix, nor did removing
> the 
> > saved key and repeating.
> >
> > Any suggestions?
> >
> > Thanks.
> >
> >
> >   
> My best guess:
> The stored key issue was symptomatic of the problem resolving host to
> ip 
> address incorrectly.
> 
> There are three things to check:
> 1) Logged on at host A, what does 'host B' command return for 
> information?  Is it the correct address for B?  If the wrong address 
> then you need to research whether your dns server or an /etc/hosts
> entry 
> is the cause.

Keeping in mind that this all worked previously ....
The 'domain' is mtranch.com. Quotes because its not a registered domain
Host A is mtranch.mtranch.com, host B is pvr.mtranch.com

host B on A:
root mtranch[9]->host pvr
pvr.mtranch.com has address 63.251.179.5
Host pvr.mtranch.com not found: 3(NXDOMAIN)
Host pvr.mtranch.com not found: 3(NXDOMAIN)

I believe that 63.251.179.5 is my ISP's (I'm on satelite with a dynamic 
IP address) DNS server.

root mtranch[16]->ping pvr
PING pvr.mtranch.com (192.168.10.4) 56(84) bytes of data.

That's the IP address that's in /etc/hosts. Other direction also works.

If I go over to pvr, I can ssh to mtranch. However, if I try to NFS 
mount directories on mtranch (A) to pvr (B) that fails with 
"Permission Denied". Again, worked fine yesterday.

> 2) Whatever user you do this as on host A, is there a ~/.ssh/config 
> file?  And if so, does it have a stanza that defines how to contact
> host 
> B, but do so with the wrong name or ip address?

There's no ~/.ssh/config, and /etc/ssh/ssh_config is the stock version 
from Fedora 10

> 3) It is also possible, but less likely, that on host A you have dnat 
> rules in iptables causing the endpoint for that ssh tcp connection to
> be 
> changed to a local host based address.

I disabled the firewall (I'm using Firestarter); no change in behavior






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]