[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problem with NM and wired /wireless network



> I have F10 running network manager
>
> Both wireless and wireless work fine independently, however when
> network cable is plugged in wireless says it is connected (as per
> applet) but cannot access any sites .
>
> Any idea what is going on here?

You have two network connections activated, quite likely on the same
network, and the traffic isn't sure which way it's supposed to
leave/return to your system?

I have seen something like you describe, possibly the same thing.

If you use the wireless setup at 2 different sites (with different ESSID's) then NM knows to change /etc/resolv.conf. But if you change places, and only plug in the wired connection, the wireless side still thinks it is at the 'old' spot and never gets a good DNS address. When this happens, run iwconfig from the command line and it will tell you which ESSID is thinks it should be talking to.

In one sense the answer is to run the wired connection with service network start in a script which sets the proper DNS for the site, and the wireless with NM only. (When I say 'proper DNS' I mean the you run script which swaps /etc/resolv.conf.home and /etc/resolv.conf.office ass required.)

Geoff


--
        Please let me know if anything I say offends you.
         I may wish to offend you again in the future.

         Tux says: "Be regular. Eat cron flakes."


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]