[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fedora 11 network share browsing using Natuilus with Samba -Fixed?



Tim;

Thanks for the advise. I made the changes I outlined, based on the info I read on the cited web site, and the system is working fine now. I think the big one was changing the order of the name resolution methods.

As far as reading the "man samba.conf" file, no. I do have the Samba book however. Trying to find the root cause of the problem wasn't very intuitive. There is a section on NetBIOS name resolution but somehow I missed it. Plus when Nautilus pops up a screen saying it can't retrieve the file list from the server wasn't helpful. Then looking at the machines listed I saw at least a couple of them show up but you couldn't browse even those machines. Nothing was making much sense. I suppose if none showed up it would have been a bigger clue, at least for me.

I wonder why simple share browsing has worked on every version of Fedora I tried, except for 11, including 12. All I can think of is some how the default order was swapped around, maybe, for some reason only the developers of the distro can answer. Of course I could be wrong, but it was odd never the less. I was almost at the point of dumping F11 completely just because of this one issue alone.

Right now I have Windows XP Pro running in a newly installed VM on my dual core experimental box, the F11 one, and I don't see any shares, other than the host, show up. I'm not really surprised by this since the VM is on a different subnet from all of the other machines on my home LAN. I think one solution is setting up one box as a "domain browse master" and not a simple "local browse master". If I understand things right the domain master browser should collect browse lists for all local browse masters on the domain, including any subnets my LAN, and serve them up to any inquires by any requesting client machines.

I guess setting up a dedicated Wins sever would be a clean way of doing it, but I'm a bit lazy, and I frequently mess around with the various machines. I just had to completely reinstall F12 last weekend because something happened where the entire free space on the user partition was consumed all of a sudden, all 140 GB worth of it! By what I don't know and I couldn't even get the box to reboot completely to a GUI screen without locking up solid. I had what looked like some ram sticks failing in the machine, a month back, requiring a "Red Switch" reboot multiple times over a 3 to 4 week period. Never did a file system check afterwards so I guess it finally caught up with me.

Regards;

Leland C. Scott
KC8LDO
----- Original Message ----- From: "Tim" <ignored_mailbox yahoo com au> To: "KC8LDO" <kc8ldo arrl net>; "Community assistance, encouragement, and advice for using Fedora." <fedora-list redhat com>
Sent: Tuesday, January 05, 2010 3:00 AM
Subject: Re: Fedora 11 network share browsing using Natuilus with Samba -Fixed?


On Sat, 2010-01-02 at 18:54 -0500, KC8LDO wrote:
I did an awful lot of research using Google on the network file share
browsing issue I had with Fedora 11 using Nautilus. The two things
that stand out are something the ISP's are doing and also with the
NetBIOS name resolution order done by Samba.

If you use local services that need to resolve local machine names, then
you really need to have a local name server that can do so.  No remote
name server, such as your ISP's, is going to be able to do it for you
(unless you have an ISP which allocates you individual IPs for each of
your machines, and their DNS server integrates that information into
itself - something of a rareity).

The alternative to using a local name server, is messing with your hosts
file.  Samba avoids some of that problem by trying other methods of name
resolution, first, before doing a normal DNS look up, such as you've
looked at below:

The second item is the NetBIOS name resolution order in Samba. I have
the following line in my samba.conf file:

name resolve order = lmhosts wins bcast host dhcp

Anybody care to comment about this?

Quite normal...  First it's trying name resolution using its own lmhosts
file, which you can enter machine names and IPs in (similar to the host
file, but not the same).  Then it tries a WINS server (if you have one).
Then it tries a broadcast query, hoping that the machine in question
will respond, itself.  Then it tries looking up the hosts file.
Finally, there's something to do with dhcp.

Have you looked at "man smb.conf"?


--
[tim localhost ~]$ uname -r
2.6.27.25-78.2.56.fc9.i686

Don't send private replies to my address, the mailbox is ignored.  I
read messages from the public lists.







[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]