[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Tar oddity...



On 12/22/2009 09:51 PM, Roberto Ragusa wrote:
DB wrote:

Just tried to copy the file on the F12 laptop... only 324MB of 1.7GB get
copied.
It looks like you could have some stability issues.

I would try some basic test for your hardware.
For example:

   while true; do md5sum somefilewithdimensionabout50MB; done

Are the checksum all the same or do they change? If they change,
causes could be: overclocking, bad power supply, bad RAM, bad CPU
or software issues (bad kernel, unstable drivers).

Try then with a bigger file, so it will have to read the disk.
You can try the external disk, so you will test the USB part too.
Create a file of 500MB with:

   dd if=/dev/urandom of=myfile bs=1048576 count=500

(replace 500 with what you want), then checksum it

   while true; do md5sum myfile; done

use a dimension bigger than the RAM you have on your machine,
so you defeat the caching that Linux will try to do.

Another test could be

   [create some file called a]
   cp filea fileb
   while true; do cmp -l a b;done

The idea is do have the machine do a lot of work for which you
already know the results. If you get a bad answer (a and b are
different??) you know the machine is not working well.

Ciao Roberto,

Thanks for the testing suggestions!

So.. what I get is:
-no problems when running on the F11 Desktopfor either the md5sum or the cmp, run in a while loop for a long time; -variable numbers of md5sum errors running on the F12 laptop (for example, will run 3 times with same checksum then 1 error); variable cmp errors(again, one or two clear runs then a pile of miscompares, then again several ok runs);
-Ran memtest overnight without error;
-tried the F12-KDE Livecd, sometimes ark opens the files, sometimes not (also tried various USB ports both direct & via a powered 7port hub with same results);
-tried F11-KDE Livecd, ark opens all files without error.....

On the F11 Desktop, the ark "help-about" gives ARK Version 2.13 using KDE 4.3.4,
on the F12 Laptop gives ARK version 2.13 using KDE 4.3.4,
F11 Livecd gives ARK versio 2.12, using KDE 4.2.2,
with yumex, I find that tar on the F12 is 1:22-10.fc12 arch 1686, on F11 is 2:1.22-4.fc11 arch i586, as I couldn't find any ark info through yumex, I had a look at /usr/bin/ark on both machines: on the F12 machine it is 54.7 KiB, on F11 is 143.2 Kib.

If /usr/bin/ark is fubared, any idea how I can best put it right?

Again, many thanks for your help

Dave



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]