[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Fedora 12: no sound update



As root when I execute:
# aplay -L
default
    Default
front:CARD=Intel,DEV=0
    HDA Intel, AD198x Analog
    Front speakers
surround40:CARD=Intel,DEV=0
    HDA Intel, AD198x Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=Intel,DEV=0
    HDA Intel, AD198x Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Intel,DEV=0
    HDA Intel, AD198x Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Intel,DEV=0
    HDA Intel, AD198x Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Intel,DEV=0
    HDA Intel, AD198x Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Intel,DEV=0
    HDA Intel, AD198x Digital
    IEC958 (S/PDIF) Digital Audio Output

but as a user, I get only;
> aplay -L
default
    Default

So I chmod-ed some files:

# cd /dev/snd
# chmod 666 hwC0D0 pcmC0D0c pcmC0D0p pcmC0D1c  pcmC0D1p seq timer
# chmod 666 /dev/mixer* /dev/midi* /dev/dsp* /dev/sequencer*

and now as a user I get the same device listing.

Now, when I execute:
> aplay -vv /path/to/file.wav
I get no sound, but if I execute:
> aplay -vv -D front:CARD=Intel,DEV=0 /path/to/file.wav
I get sound.

So, how do I make one of the "Card" devices the default
sound device?

Richard


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]