[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Setting up Tigervnc [FAILED] ?!?



William Case wrote:
>
>> First of all....  Why not try something "simple" by dumping the
>> VNCSERVERARGS line since it may confuse things since "nolisten tcp"
>> prevents X connections to your VNC server via TCP and -localhost will
>> prevent remote VNC clients connecting except when doing so through a
>> secure tunnel. 
>>     
>
> I have commented out VNCSERVERARGS line.  It may make things simpler,
> but just about every site I consulted today plus the man pages suggested
> I needed it.  That's my defence, and I'm sticking to it -- your right
> about making things simpler at the start but no one tells one that it
> isn't absolutely needed.
>   
Those arguments aren't absolutely nor needed.  Depends on your
environment and the need for added security.  In my case vnc is only
used on the LAN and not exposed to the internet.  So, no need to force
users to go through a secure tunnel.
>   
>>>                                                            [FAILED]
>>> ]# vncviewer  (I get a screen asking for VNC server but no answer
>>> satisfies.  Tried name/address (192.168.1.7) of other machine and get --
>>> main:        unable connect to socket: No route to host (113))
>>>   
>>>       
>> Don't forget that the format of vncviewer is "vncviewer [options]
>> [host][:display#]" 
>>
>>     
> ]# vncviewer localhost:0  -- gave me a screen on display 0 -- once, then
> no more.  From there I tried various combinations of localhost, address,
> and bill, and :0 & :1.  hostname is CASE so I tried that too.  bill is
> user name and host alias, nada.
>
> Not surprising.  Because my vncserver wasn't running.  
>   
You don't want to use screen 0 in a single monitor environment since
that screen is already claimed by Xorg.
>
>   
>> So, if you started vncserver using VNCSERVERS="1:bill" and you start
>> vncviewer on the same machine with no parameters you'd use.... "localhost:1"
>>
>>     
>
> ]$ service vncserver status
> Xvnc is stopped
>
> root]# service vncserver start
> Starting VNC server: 1:bill                                [FAILED]
>
> user]$ service vncserver start
> Starting VNC server: 1:bill runuser: cannot set groups: Operation not
> permitted
>                                                            [FAILED]
>   
That last one failed since you tried starting the service as a regular user.
> I even restarted just to clear out the cobwebs.
>
>   
>> Remember that if you are connecting from a remote host you'll need to
>> change your firewall settings assuming you are running a firewall.
>>
>>     
> Firewall has been changed.  I can have another go at it, but the error
> seems to be at my vncserver level first.  Probably SELinux.
>
> My frustration level is getting too high for now.  A good drink and a
> sleep and I'll try again in the morning.
>   
But....  I now know what is most likely causing your problem.... 

Your user "bill" probably doesn't have a ~/.vnc directory with the
requisite files, passwd and xstartup.

So, before you can start up a service for this user you'll need to start
the server as the user and complete the prompts for "password"

So....

1.  Login as bill
2.  Enter "vncserver"
3.  Follow the prompts
4.  Stop the server with "vncserver -kill :X" where X= the number
presented to you in the line similar to this...

New 'f12.greshko.com:1 (gnomer)' desktop is f12.greshko.com:1   (My X
would be 1)

5.  Now you can go ahead and configure the vncserver service.

Sorry to be slow to remember this....  I always run vncserver from the
command line and hardly ever use the service.  But, when I do...I've
already run vncserver directly under the user's account.  And, that is
my defense...  :-) :-)


 

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]