[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: BuildRequires on python-abi



On Tue, Apr 05, 2005 at 03:17:53AM -0400, seth vidal wrote:
> Hey folks,
>  I was looking at some packages with:
> 
> BuildRequires: python-abi = %{pyver}
> 
> when this is in an srpm, built on fc3 it comes out as python-abi = 2.3
> when you try to rebuild this srpm on rawhide it is impossible to provide
> the buildreq b/c nothing provides python-abi = 2.3.
> 
> So I was thinking - wouldn't it make sense for a buildrequires on
> python-abi to be >= %{pyver}?

I expect this was just a braino on someone's part, it should have been
Requires not BuildRequires; but the brp-* scripts do it automatically
these days so it should probably be removed from spec files on sight
now.

joe


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]