[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Perl modules that may be updated



Hi,

I have started cooking a couple of scripts to crosscheck information
regarding perl related packages in FE (right now only perl-* packages).

The list below represents a possible list of perl modules [1] that
*could* be updated by their maintainers. I say could because some of
the modules may require additional reqs not yet available, may need
perl core modules that will only be available in perl 5.8.8, etc.


Development repodata vs CPAN 02packages.details.txt+blacklist
---------------------------------------------------------------------
 * Apache-Session-1.6 (Apache-Session-1.80.tar.gz)
 * Class-Autouse-1.21 (Class-Autouse-1.24.tar.gz)
 * Class-DBI-0.96 (Class-DBI-v3.0.14.tar.gz)
 * Class-DBI-AbstractSearch-0.05 (Class-DBI-AbstractSearch-0.07.tar.gz)
 * Class-DBI-Loader-0.22 (Class-DBI-Loader-0.29.tar.gz)
 * Class-DBI-Pg-0.06 (Class-DBI-Pg-0.07.tar.gz)
 * Class-DBI-Plugin-RetrieveAll-1.02
(Class-DBI-Plugin-RetrieveAll-1.04.tar.gz)
 * Class-MethodMaker-2.06 (Class-MethodMaker-2.08.tar.gz)
 * Crypt-Blowfish-2.09 (Crypt-Blowfish-2.10.tar.gz)
 * Crypt-CBC-2.14 (Crypt-CBC-2.15.tar.gz)
 * Exception-Class-1.22 (Exception-Class-1.23.tar.gz)
 * File-Slurp-9999.09 (File-Slurp-9999.11.tar.gz)
 * Image-ExifTool-5.89 (Image-ExifTool-5.87.tar.gz; see also the
author's homepage)
 * Imager-0.45 (Imager-0.47.tar.gz)
 * Mail-SPF-Query-1.997 (Mail-SPF-Query-1.998.tar.gz)
 * Net-CIDR-Lite-0.18 (Net-CIDR-Lite-0.19.tar.gz)
 * Net-Patricia-1.010 (Net-Patricia-1.014.tar.gz)
 * Params-Validate-0.79 (Params-Validate-0.80.tar.gz)
 * Spreadsheet-WriteExcel-2.15 (Spreadsheet-WriteExcel-2.16.tar.gz)
 * Test-Builder-Tester-1.01 (v1.02 is a perl 5.8.8 core module)
 * Test-MockObject-0.15 (Test-MockObject-1.02.tar.gz)
 * Test-Pod-1.20 (Test-Pod-1.22.tar.gz)
 * Unicode-MapUTF8-1.09 (Unicode-MapUTF8-1.11.tar.gz)
 * Unicode-String-2.07 (Unicode-String-2.09.tar.gz)
 * Unix-Statgrab-0.03 (Unix-Statgrab-0.04.tar.gz)
 * Unix-Syslog-0.100 (Unix-Syslog-0.99.tar.gz)
 * X11-Protocol-0.54 (X11-Protocol-0.55.tar.gz)
 * libintl-1.11 (libintl-perl-1.16.tar.gz)
 * version-0.51 (version-0.53.tar.gz)


I would appreciate if the maintainers of the listed modules could
update them and/or report any problems, false positives to me.


Thanks in advance,
jpo

References:
[1] - Obtained by crosschecking the development repository version
against the latest version available in CPAN.

PS - Test-Builder-Tester, Test-MockObject, and Test-Pod are mine:
 * Test-Builder-Tester - the latest version is a perl 5.8.8 core module
 * Test-MockObject - requires new perl modules (IIRC one of them
                     requires perl 5.8.8)
 * Test-Pod - requires perl 5.8.8 (Test::Builder::Tester, Test::More)

-- 
José Pedro Oliveira
* mailto: jpo di uminho pt * http://gsd.di.uminho.pt/jpo *
* gpg fingerprint = F9B6 8D87 859D 1C94 48F0 84C0 9749 9EB5 91BD 851B *

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]