[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Error output from rpm pre/post scripts (was Re: Florian La Roche please stop mass filing bugs)



On Thursday 05 July 2007, Hans de Goede wrote:
> Florian La Roche wrote:
>
> > The error output is a real bug, so just closing this is not very
> > good.
>
> I agree that its a bug. However as said the scriptlet recipe was changed
> from checking to not checking, I'm sure this was discussed and there were
> reasons. So lets first discuss this with the people who made this change.

Well, I don't remember if I was involved in that, but if we don't want the 
scriptlet to fail and don't want to display the error output (no matter 
whether it's because of a missing executable or some other error running it), 
dunno if checking first adds any value.

Not adding the dependency is there because it'd pull in GTK to non-GTK setups 
for no gain.  This is fine and should be preserved, but actually, I think the 
snippet/guideline should be changed so that the Requires(post) and 
Requires(postun) dependencies *should* be added in cases where the packaged 
app requires GTK itself anyway, and left out just like currently if it 
doesn't.  Opinions?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]