[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: foo vs. foo+



On Sat, Jul 21, 2007 at 12:50:35PM +0300, Ville Skyttä wrote:
> On Saturday 21 July 2007, Patrice Dumas wrote:
> > On Sat, Jul 21, 2007 at 04:15:19AM +0200, Christoph Wickert wrote:
> > > Ok so far, but foo+ also needs a "Provides: foo", and I wonder if is
> > >   Provides: foo
> > >   Conflicts: foo
> > > really is a good idea. And can/should we use versioned Provides: here?
> >
> > Unless I am wrong, yum (rpm) won't care about versioned Provides:, and
> > replace foo+ with foo (I had such issues with libnet10/libnet).
> 
> Do you have a test case available where rpm/yum ignores the version?

For "Provides: foo" and "Requires: foo >= 1.0" the version information
is just ignored and this always matches.

I've written a small test, so that all such cases can be listed and they
can get screened for real problem cases. Output for the current Fedora-devel
tree looks like:


jakarta-commons-codec-1.3-7jpp.2.i386.rpm should have a flag/version added for the provides (commons-codec >= 1.3)
initng-ifiles-0.1.3-1.fc8.i386.rpm should have a flag/version added for the provides (initng(ifiles) >= 0.1.2)
paraview-mpi-3.0.2-1.fc8.i386.rpm should have a flag/version added for the provides (paraview = 3.0.2-1.fc8)
perl-5.8.8-19.fc8.i386.rpm should have a flag/version added for the provides (perl(CGI) >= 2.81)
perl-Cairo-1.041-1.fc8.i386.rpm should have a flag/version added for the provides (perl(Cairo) >= 1.00)
perl-Class-Accessor-0.30-1.fc7.noarch.rpm should have a flag/version added for the provides (perl(Class::Accessor::Fast) >= 0.19)
perl-Class-DBI-3.0.16-1.fc7.noarch.rpm should have a flag/version added for the provides (perl(Class::DBI) >= 0.90)
perl-Compress-Raw-Bzip2-2.005-2.fc8.i386.rpm should have a flag/version added for the provides (perl(Compress::Raw::Bzip2) >= 2.005)
perl-Config-General-2.33-1.fc7.noarch.rpm should have a flag/version added for the provides (perl(Config::General) >= 1.18)
perl-Config-General-2.33-1.fc7.noarch.rpm should have a flag/version added for the provides (perl(Config::General) >= 2.19)
perl-DateManip-5.44-3.fc7.noarch.rpm should have a flag/version added for the provides (perl(Date::Manip) >= 5.00)
perl-Email-Simple-1.999-1.fc7.noarch.rpm should have a flag/version added for the provides (perl(Email::Simple) >= 1.91)
perl-5.8.8-19.fc8.i386.rpm should have a flag/version added for the provides (perl(Getopt::Long) >= 2.01)
perl-5.8.8-19.fc8.i386.rpm should have a flag/version added for the provides (perl(Getopt::Long) >= 2.17)
perl-5.8.8-19.fc8.i386.rpm should have a flag/version added for the provides (perl(Getopt::Long) >= 2.25)
perl-Glib-1.144-1.fc7.i386.rpm should have a flag/version added for the provides (perl(Glib) >= 1.140)
perl-HTML-Template-2.9-1.fc7.noarch.rpm should have a flag/version added for the provides (perl(HTML::Template) >= 2.4)
perl-HTML-Template-2.9-1.fc7.noarch.rpm should have a flag/version added for the provides (perl(HTML::Template) >= 2.6)
perl-IO-Compress-Base-2.005-2.fc8.noarch.rpm should have a flag/version added for the provides (perl(IO::Compress::Base::Common) >= 2.005)
perl-IO-Compress-Base-2.005-2.fc8.noarch.rpm should have a flag/version added for the provides (perl(IO::Uncompress::Base) >= 2.005)
perl-Kwiki-Revisions-0.15-5.fc7.noarch.rpm should have a flag/version added for the provides (perl(Kwiki::Revisions) >= 0.12)
perl-Locale-Maketext-Lexicon-0.64-1.fc8.noarch.rpm should have a flag/version added for the provides (perl(Locale::Maketext::Lexicon) >= 0.20)
perl-Locale-Maketext-Lexicon-0.64-1.fc8.noarch.rpm should have a flag/version added for the provides (perl(Locale::Maketext::Lexicon) >= 0.25)
perl-Params-Validate-0.88-1.fc7.i386.rpm should have a flag/version added for the provides (perl(Params::Validate) >= 0.23)
perl-Params-Validate-0.88-1.fc7.i386.rpm should have a flag/version added for the provides (perl(Params::Validate) >= 0.7)
perl-Params-Validate-0.88-1.fc7.i386.rpm should have a flag/version added for the provides (perl(Params::Validate) >= 0.76)
perl-Readonly-1.03-6.fc6.noarch.rpm should have a flag/version added for the provides (perl(Readonly) >= 1.02)
subversion-perl-1.4.3-4.i386.rpm should have a flag/version added for the provides (perl(SVN::Core) >= 1.0.7)
perl-Spiffy-0.30-7.fc7.noarch.rpm should have a flag/version added for the provides (perl(Spiffy) >= 0.21)
perl-Spiffy-0.30-7.fc7.noarch.rpm should have a flag/version added for the provides (perl(Spiffy) >= 0.22)
perl-Time-Piece-MySQL-0.05-3.fc6.noarch.rpm should have a flag/version added for the provides (perl(Time::Piece) >= 1.03)
perl-Tk-804.027-11.fc7.i386.rpm should have a flag/version added for the provides (perl(Tk) >= 800.005)
perl-Tk-804.027-11.fc7.i386.rpm should have a flag/version added for the provides (perl(Tk) >= 800.015)
perl-Tk-804.027-11.fc7.i386.rpm should have a flag/version added for the provides (perl(Tk) >= 800.021)
perl-Tk-804.027-11.fc7.i386.rpm should have a flag/version added for the provides (perl(Tk) >= 800.022)
perl-Tk-804.027-11.fc7.i386.rpm should have a flag/version added for the provides (perl(Tk) >= 804.000)
maxima-runtime-sbcl-5.12.0-3.fc8.i386.rpm did not find a package for: (sbcl = 1.0.6)
tomcat5-servlet-2.4-api-5.5.23-9jpp.2.fc7.i386.rpm should have a flag/version added for the provides (servletapi5 >= 0:5.0.16)

So this is mostly hit by perl rpms and then a few others. Shouldn't be a big
thing to clean up overall.

regards,

Florian La Roche


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]