[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Fedora-music-list] Re: Mixer Wowes



David Timms wrote:
William M. Quarles wrote:
 > David Timms wrote:
 >> William M. Quarles wrote:
 >>> I have Fedora 10 and a machine with a (please, no laughing or
 >>> snickering) Creative Labs Sound Blaster AWE 64 Value sound card and a
 >>> Sigma Designs RealMagic Hollywood Plus DVD decoder card. While the
 >>> computer loads the ALSA drivers needed for both cards,
 >> As evidenced by ?
 >
> Uh, as evidenced by lsmod? I'm not a newbie if that's what you're implying.
Yes, but really was it an alsa util you used, lsmod or looking at /proc ?

lsmod and /proc were used, and they were used before I wrote the original message, thank you.


 > [root quarlewm ~]# lsmod
I suggested grep snd so that we would get sound related modules, not the
whole thing. It's just faster to look at the reduced version. I can
however see all the modules seem to be linked up.

I know you did make that suggestion. I had different purposes in mind, as it seems you inadvertently stumbled upon them.

 >> I'm not sure which mod the awe needs, but check lsmod |grep snd
 >> Maybe fpaste.org your alsa-info results for others to check
 >
 > The AWE 64 cards use snd-sbawe module, which can be easily checked on
 > http://www.alsa-project.org/'s sound card matrix.
Given that your asking for help, I probably won't be going searching
sites to try to find appropriate info; I'll ask you to, or you could
offer that info, and hence we know what you've tried.

 > I have no idea what you mean by fpaste.org
One of many paste-bin web sites. These allow anonymous (you do need to
supply an email address that is used to limit bad usage of the site)
text upload site. It's really just a holder for bits of text from logs /
compiles etc that would unnecessarily fill up mailing list user's email
boxes.
http://fpaste.org is targeted towards Fedora users.

Great, guess I'm a old fogey not up on the current trends. Then again, I did stop using GNU/Linux for about three or four years up until recently.

I uploaded my alsa-info.txt to <http://fpaste.org/paste/11316>.

 >, but alsa-info does seem like
 > a good idea in this case; however it also unfortunately seems a little
 > useless since it reveals a great deal of output, but I can't copy and
 > paste any of it into this post
That's the point of the paste-bin, we don't really want large log files
in our email boxes.

This stuff should all be in newsgroups anyway, that's why I am very glad to have found out about GMANE back around when Fedora Core 1 came out.

 > , and the final message upon exiting the program says:
 >
 >     Your ALSA information is located at
 >     Please inform the person helping you.
 >
 > So, uh, LOCATED AT big blank?
Yeah, that didn't work out well:
Your ALSA information is located at
http://www.alsa-project.org/db/?f=23db04e4a7aeaa23357d00481f38b86638e90b21

Please inform the person helping you.
$

Well it normally pastes to the alsa project pastebin, and gives the link
(which worked for me). I'm guessing your internet/web access is normal,
so perhaps this is further indication of something going wrong during
alsa calls ?

Define normal. I'm using a docked Win XP Pro laptop right now as a router.

 > Gee, diagnostic program.
has a --help capability:
alsa-info --help
  shows a debug option, that stores the large alsa log on your local
disk so that you could manually put it on a pastebin, and post the link
back here.

I know that it has a help function, but I did not know that the debug option left the log file that we were looking for behind on the hard drive. It would make more sense to me if they did both a local dump and an upload simultaneously.

However, since you suggested, I tried the debug option. The program left the file behind, but not where the help function said that it would leave it behind, so basically there is a bug in the debug function, or a bug in the help function. depending on your point of view I suppose.

Curiosity, alsa-info is offering to update itself, which I didn't do in hear of breaking any Fedora customizations. Did you do the update? Would you suggest that I do the update?

 >>> the sound controls in GNOME only display the Hollywood+ controls, and
 >>> nothing is available for the AWE 64.
Bugger.

You betcha.

 > [root quarlewm ~]# alsamixer
 > ALSA lib pulse.c:272:(pulse_connect) PulseAudio: Unable to connect:
 > Connection refused
If pulseaudio wasn't running, I think you would get a different error like:
$ alsamixer
E: socket-client.c: socket(): Address family not supported by protocol
 > alsamixer: function snd_ctl_open failed for default: Connection refused

alsamixer decided to work today. ;-) Or maybe it was Pulseaudio, which is new to me. Same stuff as in the GNOME mixer, unfortuntely.

 > [root quarlewm ~]# alsaunmute
 > Unknown hardware: "SB AWE" "CTL1745" "CTL1745" "" ""
 > Hardware is initialized using a guess method
 > /lib/alsa/init/default:17: unable to convert dB value '-20dB' to
 > internal integer range
Mine:
$ alsaunmute
Unknown hardware: "CA0106" "" "" "" ""
Hardware is initialized using a guess method
$

alsaunmute behaved the same as yesterday, pretty much.

I guess aplay wont work either ?

It doesn't seem to... then again I don't have a file on hand for it to play.

alsamixer -c0 ?

Wow, that's the spirit! So how do I get the GNOME sound stuff to recognize it?

ps aux|grep -E 'pad|pav|pul'

I'm assuming playback is a problem as well, not just mixer control ?

Well, now that alsamixer is working, yes, I am getting sound. Do you know how to fix the GNOME mixer issues?

Do you have the option to try without the decoder card installed, for a
giggle ?

DaveT.


Yeah, I can give that a shot, I'll get back to you on it. But please, give me a reply to what I have written here already before I do.

Thanks,
William


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]