[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

rpms/ocaml-lablgtk/devel .cvsignore, 1.8, 1.9 ocaml-lablgtk.spec, 1.18, 1.19 sources, 1.8, 1.9 ocaml-lablgtk-2.12.0-gnome-ui-init-header.patch, 1.1, NONE



Author: rjones

Update of /cvs/pkgs/rpms/ocaml-lablgtk/devel
In directory cvs1.fedora.phx.redhat.com:/tmp/cvs-serv6576

Modified Files:
	.cvsignore ocaml-lablgtk.spec sources 
Removed Files:
	ocaml-lablgtk-2.12.0-gnome-ui-init-header.patch 
Log Message:
New upstream 2.14.0


Index: .cvsignore
===================================================================
RCS file: /cvs/pkgs/rpms/ocaml-lablgtk/devel/.cvsignore,v
retrieving revision 1.8
retrieving revision 1.9
diff -u -p -r1.8 -r1.9
--- .cvsignore	6 Feb 2009 12:12:38 -0000	1.8
+++ .cvsignore	28 Sep 2009 15:35:05 -0000	1.9
@@ -1 +1 @@
-lablgtk-2.12.0.tar.gz
+lablgtk-2.14.0.tar.gz


Index: ocaml-lablgtk.spec
===================================================================
RCS file: /cvs/pkgs/rpms/ocaml-lablgtk/devel/ocaml-lablgtk.spec,v
retrieving revision 1.18
retrieving revision 1.19
diff -u -p -r1.18 -r1.19
--- ocaml-lablgtk.spec	25 Jul 2009 19:58:30 -0000	1.18
+++ ocaml-lablgtk.spec	28 Sep 2009 15:35:05 -0000	1.19
@@ -1,8 +1,8 @@
 %define debug_package %{nil}
 
 Name:           ocaml-lablgtk
-Version:        2.12.0
-Release:        4%{?dist}
+Version:        2.14.0
+Release:        1%{?dist}
 
 Summary:        Objective Caml interface to gtk+
 
@@ -12,15 +12,13 @@ License:        LGPLv2 with exceptions
 URL:            http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/lablgtk.html
 Source:         http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/dist/lablgtk-%{version}.tar.gz
 
-Patch0:         ocaml-lablgtk-2.12.0-gnome-ui-init-header.patch
-
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 ExcludeArch:    sparc64 s390 s390x
 
 Obsoletes:      lablgtk <= 2.6.0-7
 Provides:       lablgtk = 2.6.0-7
 
-BuildRequires:	ncurses-devel
+BuildRequires:  ncurses-devel
 BuildRequires:  gnome-panel-devel
 BuildRequires:  gtk2-devel
 BuildRequires:  gtkglarea2-devel
@@ -74,8 +72,6 @@ developing applications that use %{name}
 %prep
 %setup -q -n lablgtk-%{version}
 
-%patch0 -p1
-
 # version information in META file is wrong
 perl -pi -e 's|version="1.3.1"|version="%{version}"|' META
 
@@ -124,6 +120,7 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/ocaml/lablgtk2
 %{_libdir}/ocaml/lablgtk2/*.cmi
 %{_libdir}/ocaml/lablgtk2/*.cma
+%{_libdir}/ocaml/lablgtk2/*.cmxs
 %{_libdir}/ocaml/stublibs/*.so
 %{_bindir}/gdk_pixbuf_mlsource
 %{_bindir}/lablgladecc2
@@ -156,6 +153,12 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Mon Sep 28 2009 Richard W.M. Jones <rjones redhat com> - 2.14.0-1
+- New upstream version 2.14.0.
+- Patch to fix ml_panel.c is now upstream, so removed.
+- New *.cmxs files (dynamically linked OCaml native code) added to
+  the base package.
+
 * Sat Jul 25 2009 Fedora Release Engineering <rel-eng lists fedoraproject org> - 2.12.0-4
 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
 


Index: sources
===================================================================
RCS file: /cvs/pkgs/rpms/ocaml-lablgtk/devel/sources,v
retrieving revision 1.8
retrieving revision 1.9
diff -u -p -r1.8 -r1.9
--- sources	6 Feb 2009 12:12:38 -0000	1.8
+++ sources	28 Sep 2009 15:35:05 -0000	1.9
@@ -1 +1 @@
-0e253128afee3cdc6e9b43c34b35984d  lablgtk-2.12.0.tar.gz
+8a26ab3b749ea86d06b2868112332c33  lablgtk-2.14.0.tar.gz


--- ocaml-lablgtk-2.12.0-gnome-ui-init-header.patch DELETED ---


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]