[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

rpms/ocaml-ocamlnet/devel ocaml-ocamlnet.spec,1.19,1.20



Author: rjones

Update of /cvs/pkgs/rpms/ocaml-ocamlnet/devel
In directory cvs1.fedora.phx.redhat.com:/tmp/cvs-serv25634

Modified Files:
	ocaml-ocamlnet.spec 
Log Message:
- {gtk2,openssl,pcre,tcl}-devel BRs have now been pushed down to the
  corresponding ocaml-X-devel packages, so we don't need those here
  any more.



Index: ocaml-ocamlnet.spec
===================================================================
RCS file: /cvs/pkgs/rpms/ocaml-ocamlnet/devel/ocaml-ocamlnet.spec,v
retrieving revision 1.19
retrieving revision 1.20
diff -u -p -r1.19 -r1.20
--- ocaml-ocamlnet.spec	5 Jan 2010 13:32:43 -0000	1.19
+++ ocaml-ocamlnet.spec	5 Jan 2010 13:44:37 -0000	1.20
@@ -6,7 +6,7 @@
 
 Name:           ocaml-ocamlnet
 Version:        2.2.9
-Release:        18%{?dist}
+Release:        19%{?dist}
 Summary:        Network protocols for OCaml
 
 Group:          Development/Libraries
@@ -26,15 +26,6 @@ BuildRequires:  ocaml-findlib-devel
 BuildRequires:  ocaml-pcre-devel
 BuildRequires:  ocaml-ssl-devel
 BuildRequires:  ocaml-lablgtk-devel
-# These BRs should be pushed down (as simple Requires) to the respective
-# ocaml-X-devel packages.  For example, building something against
-# lablgtk currently gives:
-# Error: Error on dynamically loaded library: /usr/lib64/ocaml/stublibs/dlllablgtk2.so: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory
-# if gtk2-devel is not installed separately.
-BuildRequires:  pcre-devel
-BuildRequires:  openssl-devel
-BuildRequires:  tcl-devel
-BuildRequires:  gtk2-devel
 
 %global __ocaml_requires_opts -i Asttypes -i Outcometree -i Parsetree
 
@@ -247,6 +238,11 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Tue Jan  5 2010 Richard W.M. Jones <rjones redhat com> - 2.2.9-19
+- {gtk2,openssl,pcre,tcl}-devel BRs have now been pushed down to the
+  corresponding ocaml-X-devel packages, so we don't need those here
+  any more.
+
 * Tue Jan  5 2010 Richard W.M. Jones <rjones redhat com> - 2.2.9-18
 - Use new dependency generator in upstream RPM 4.8.
 - Add BR gtk2-devel.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]