[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: move to rawhide update



You don't need to do an exhaustive search on bugzilla. You just need
to search against the component that's causing issues. eg totem media
player. Generally most components will have < 10 bugs so its easy to
see if its an issue for the component.

In another post you yourself said "I'm trying to help but I'm not god". 'components' are one of my biggest problems -- I feel I would have to have a god's knowledge to figure them out. [This was my principal problem with filing tickets on dev.laptop.org -- I had not the slightest idea of what was within the scope of each 'component'.]

[I'm not a kid -- but assume that I were. Suppose in my XO I click on a video in Journal (and actually it would be quite difficult for me to describe how it came to be there). I would expect to see on the XO's screen something that I would call "moving pictures" (as opposed to something that I would call "static pictures"). If I don't see "moving pictures" when I expect to see them, how am I supposed to know which 'component' should be pointed at. I was using an XO -- I guess the 'component' should be an 'XO'.]

By the way, the year-ago XO software did not have anything called "totem" installed. Instead it provided a "helper" Activity called 'Watch&Listen', which was some kind of port of what you call Totem. How am I supposed to divine that on fedora-xo this same "helper" capability needs to be referred to by the name 'Totem'?

And regarding bugzilla search - when yum did not work for me with ~cjb's image, I wrote a problem report. Just now I tried to find that problem report (using bugzilla search) - and none of the bugs it listed for me were what I wrote. PLEASE tell me how to search against 'yum' (I presume it's a 'component') using bugzilla search (as if the bug # had been forgotten)!

But if your going to have an attitude of its a waste of your time,
I won't waste my time trying to get them to work for you.

While it would be nice for you to get something to work for me -- that is not the reason why I "publicize" problems. I figure that if something does not work for me, it will also not work for other people. And my personal concept of a "bug response" is that by spending the time of a few people (let's call them developers), a much larger group of other people (let's call them users) will be saved the time and aggravation of running into "no go" situations.

If I were being paid to write test cases (conforming to fedora bugzilla conventions), I would put the effort in (to get something to work for me). But if I volunteer "here's something I can't use", I would expect (perhaps wrongly) for those responsible for preparing the product to ask themselves "is this something which could affect a lot of the users of the product?" And if the conclusion were "yes", then let me suggest that it would be more constructive to assess the problem, instead of a reflexive "Are there bugzilla reports for these?" directed to whoever mentions the difficulty.

You talk about my attitude. It was formed eons ago by incidents like the following: I submitted an APAR (with all required fields filled in) about a _software_ error in a package written by IBM (I called that package correctly according to its documentation, but the information it returned was incorrect). IBM rejected the APAR with the notation "this problem was reported on an EISA system - we don't have any EISA systems on which to reproduce the problem". I doubt very much that a software routine would change its output depending on whether the system it was running on used ISA or EISA - yet this _hardware_ detail was used by IBM as a reason to refuse to act on that bug report.

[Let me illustrate my feeling of "wasting my time" with bug #487101.
I installed the rawhide-xo image. I use yum to download additional packages, but, given the communications configuration I use, yum on that XO would not work. Since yum is fedora-supplied, I wrote that bug report. I got questions on this bug report, and spent (too many) hours finding the answers - but despite me providing what asked-for information I could, the bug report went nowhere. Finally, by trawling through bugzilla, I found where someone else (not using an XO) had discovered a bypass. Now I am doing an edit of the appropriate configuration file every time I install F-11.]

[Only yesterday did an F-11 XO image become available with a new version of Browse. (The previous version did not work for me.) I have not yet had time to compare 'yum' with https vs. Browse with https, to see if the problem is with 'yum' or with "https support" in the XO. (And no, I would have no idea of what 'component' "https support" would fall under.)]

... if the person that want helps
isn't prepared to do some legwork why should I.

I'll say it again : I'm not the person that wants help.

I'm drawing attention to some problems because I am of the opinion that there will be other persons who will encounter these problems.

I'm quite prepared to help him if he'll provide the information.

There's not a lot that can
be done unless he at least states what application it is.

I'm sorry - but I do NOT know how to provide the "information" (particularly 'steps to reproduce'). Why do I have to explain what I mean by "moving pictures" - surely "movie", "movie theatre", etc., are not unknown concepts (they grew out of "moving pictures"). If someone else had tried (in any way whatsoever) to watch a movie on F-11 XO, and that succeeded, I would consider it a refutation of what I posted. But to 'reproduce' inability to "watch a movie" -- I simply do not function/think that way.

And I do NOT have an "application" that does not work. I see a "function" that does not work. [By that I mean, *every* way that I have tried to get the "function" to work has not produced the expected audio-visual results.] I looked around at what were the most self-contained ways to get output in the form of 'sound' and 'moving pictures' - and settled on Fluendo and Mplayer. You say that they are unacceptable, since they were not supplied by Fedora. Well, damn it, let someone less volatile than me supply "acceptable" information. But I predict that if F-11 XO gets out of development in the shape it was last week, that will give more ammunition to those dissing the XO.

I'm someone who has done a _lot_ of very
patient bug testing and trying to get all the OLPC changes to Fedora
upstream so that we have the best release possible.

This is now guesswork on my part (and I could be completely wrong), but I suspect the problem does not lie with pushing upstream the existing 'OLPC changes'. "Moving pictures" worked up through Joyride-2602. Then some sort of a change was made to some sort of an X11 module (I would be surprised if there were 'OLPC changes' in X11), and "moving pictures" stopped working. Likewise, "sound" appears to be a matter of changing the 'OLPC changes' to work with pulse audio (which I think is new with F-11).


mikus



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]