[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[SECURITY] Fedora Core 5 Update: ruby-1.8.4-8.fc5



---------------------------------------------------------------------
Fedora Update Notification
FEDORA-2006-849
2006-07-22
---------------------------------------------------------------------

Product     : Fedora Core 5
Name        : ruby
Version     : 1.8.4
Release     : 8.fc5
Summary     : An interpreter of object-oriented scripting language
Description :
Ruby is the interpreted scripting language for quick and easy
object-oriented programming.  It has many features to process text
files and to do system management tasks (as in Perl).  It is simple,
straight-forward, and extensible.

---------------------------------------------------------------------

* Thu Jul 20 2006 Akira TAGOH <tagoh redhat com> - 1.8.4-8
- security fixes [CVE-2006-3694]
  - ruby-1.8.4-fix-insecure-dir-operation.patch:
  - ruby-1.8.4-fix-insecure-regexp-modification.patch: fixed the insecure
    operations in the certain safe-level restrictions. (#199538)
  - ruby-1.8.4-fix-alias-safe-level.patch: fixed to not bypass the certain
    safe-level restrictions. (#199543)
* Mon Jun 19 2006 Akira TAGOH <tagoh redhat com> - 1.8.4-7.fc5
- fixed the wrong file list again. moved tcltk library into ruby-tcltk.
  (#195872)
* Thu Jun  8 2006 Akira TAGOH <tagoh redhat com> - 1.8.4-5.fc5
- ruby-deprecated-search-path.patch: applied to add more search path
  for backward compatibility.
- added byacc to BuildReq.
- exclude ppc64 to make ruby-mode package. right now emacs.ppc64 isn't provided
  and buildsys became much stricter.
* Wed May 17 2006 Akira TAGOH <tagoh redhat com> - 1.8.4-4.fc5
- correct sitelibdir. (#184198)
- ruby-rubyprefix.patch: moved all arch-independent modules under /usr/lib/ruby
  and keep arch-dependent modules under /usr/lib64/ruby for 64bit archs.
  so 'rubylibdir', 'sitelibdir' and 'sitedir' in Config::CONFIG points to
  the kind of /usr/lib/ruby now. (#184199)
- ruby-deprecated-search-path.patch: added the deprecated installation paths
  to the search path for the backward compatibility.
- added a Provides: ruby(abi) to ruby-libs.
- ruby-1.8.4-64bit-pack.patch: backport patch from upstream to fix unpack("l")
  not working on 64bit arch and integer overflow on template "w". (#189350)
- updated License tag to be more comfortable, and with a pointer to get more
  details, like Python package does. (#179933)
- clean up.

---------------------------------------------------------------------
This update can be downloaded from:
    http://download.fedora.redhat.com/pub/fedora/linux/core/updates/5/

acb40b0c3c0ded6bb01909d9bbca61150176142d  SRPMS/ruby-1.8.4-8.fc5.src.rpm
acb40b0c3c0ded6bb01909d9bbca61150176142d  noarch/ruby-1.8.4-8.fc5.src.rpm
5daca6d61d71c0f035dbb4004c6c0e54c87d4625  ppc/ruby-mode-1.8.4-8.fc5.ppc.rpm
980395706c2d27f30890f33ffad39b5e17168c1f  ppc/ruby-rdoc-1.8.4-8.fc5.ppc.rpm
698ac40f601ca8345b966c60efcb41a76d1a1c61  ppc/ruby-1.8.4-8.fc5.ppc.rpm
92c5e4ca1642c55104868666ddd58ff013ce3c27  ppc/ruby-tcltk-1.8.4-8.fc5.ppc.rpm
1f4fea9dda48b1320d96dd42bb32617d71783688  ppc/ruby-irb-1.8.4-8.fc5.ppc.rpm
a9b155ac6e7567043674a3b50c083a78e1c3b0eb  ppc/ruby-docs-1.8.4-8.fc5.ppc.rpm
7960294bfa7068209bf4d488d82fe761841e92cc  ppc/ruby-libs-1.8.4-8.fc5.ppc.rpm
9722c094faf78141ffc7b98a8becd2649ad29d26  ppc/ruby-devel-1.8.4-8.fc5.ppc.rpm
24e246b07cfcc5e2a561f001a7b03d8c8b5ec7bc  ppc/ruby-ri-1.8.4-8.fc5.ppc.rpm
fdc8125cc0d082531ee53f99a9c600a969fa4692  ppc/debug/ruby-debuginfo-1.8.4-8.fc5.ppc.rpm
7653d7e32a806224c9a28360f2248249b5ebd913  x86_64/ruby-tcltk-1.8.4-8.fc5.x86_64.rpm
f2971f4c4bc0f65f074ad6008065e874032d6416  x86_64/ruby-libs-1.8.4-8.fc5.x86_64.rpm
6e9d88c451a78e6d299986374faf825568b446a5  x86_64/ruby-rdoc-1.8.4-8.fc5.x86_64.rpm
6a1dd99ef5d9f285c3b7eac1b14c74a0a31d78aa  x86_64/ruby-ri-1.8.4-8.fc5.x86_64.rpm
292b47d444550c15b4f643baea10b2d7655a02d3  x86_64/ruby-irb-1.8.4-8.fc5.x86_64.rpm
659fa6bb7302de3c9a61e1a6d40c580d7349e544  x86_64/ruby-devel-1.8.4-8.fc5.x86_64.rpm
58732fa8ae45029cc76458e3454fd815c00e6b60  x86_64/ruby-mode-1.8.4-8.fc5.x86_64.rpm
fead392e991f8ef58f030488ada3220486a4ada3  x86_64/ruby-docs-1.8.4-8.fc5.x86_64.rpm
0d235b86422298afc838e6fd0126d22c15443784  x86_64/ruby-1.8.4-8.fc5.x86_64.rpm
7289f28d20457340778570e4c9e4c971fe99da22  x86_64/debug/ruby-debuginfo-1.8.4-8.fc5.x86_64.rpm
85ffe9ab6669e4da45acee33c025c1a8beacd9ce  i386/ruby-devel-1.8.4-8.fc5.i386.rpm
9807b56716dbdaf7e775300a5b6d2fb19f4eb778  i386/debug/ruby-debuginfo-1.8.4-8.fc5.i386.rpm
f68e046167171afe14779d3ed56621cb3f5337be  i386/ruby-docs-1.8.4-8.fc5.i386.rpm
f00617e466197aa99cfb2a8143376fa0a8591426  i386/ruby-libs-1.8.4-8.fc5.i386.rpm
3e4ddb87f55c347e6f25131199d786c1b6ffb95b  i386/ruby-1.8.4-8.fc5.i386.rpm
a15a5ad62998edeacdb98f1113b514d2c57fdf64  i386/ruby-mode-1.8.4-8.fc5.i386.rpm
a20b1e35a64cc09667884d7f1fcb255a6ec8b314  i386/ruby-irb-1.8.4-8.fc5.i386.rpm
b1336c534c556afc4e90f9468768d01a0299c978  i386/ruby-ri-1.8.4-8.fc5.i386.rpm
5a9cdf578f9c971f8a2a50a001b41853c1e241c3  i386/ruby-rdoc-1.8.4-8.fc5.i386.rpm
8f7fde81009b30d02c80bdacaf2fcbf996871b3c  i386/ruby-tcltk-1.8.4-8.fc5.i386.rpm

This update can be installed with the 'yum' update program.  Use 'yum update
package-name' at the command line.  For more information, refer to 'Managing
Software with yum,' available at http://fedora.redhat.com/docs/yum/.
---------------------------------------------------------------------


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]