[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Fedora Core 5 Update: ruby-1.8.4-6.fc5



---------------------------------------------------------------------
Fedora Update Notification
FEDORA-2006-724
2006-06-19
---------------------------------------------------------------------

Product     : Fedora Core 5
Name        : ruby
Version     : 1.8.4
Release     : 6.fc5
Summary     : An interpreter of object-oriented scripting language
Description :
Ruby is the interpreted scripting language for quick and easy
object-oriented programming.  It has many features to process text
files and to do system management tasks (as in Perl).  It is simple,
straight-forward, and extensible.

---------------------------------------------------------------------

* Mon Jun 19 2006 Akira TAGOH <tagoh redhat com> - 1.8.4-6.fc5
- fixed the wrong file list again. moved tcltk library into ruby-tcltk.
  (#194537)
* Thu Jun  8 2006 Akira TAGOH <tagoh redhat com> - 1.8.4-5.fc5
- ruby-deprecated-search-path.patch: applied to add more search path
  for backward compatibility.
- added byacc to BuildReq.
- exclude ppc64 to make ruby-mode package. right now emacs.ppc64 isn't provided
  and buildsys became much stricter.
* Wed May 17 2006 Akira TAGOH <tagoh redhat com> - 1.8.4-4.fc5
- correct sitelibdir. (#184198)
- ruby-rubyprefix.patch: moved all arch-independent modules under /usr/lib/ruby
  and keep arch-dependent modules under /usr/lib64/ruby for 64bit archs.
  so 'rubylibdir', 'sitelibdir' and 'sitedir' in Config::CONFIG points to
  the kind of /usr/lib/ruby now. (#184199)
- ruby-deprecated-search-path.patch: added the deprecated installation paths
  to the search path for the backward compatibility.
- added a Provides: ruby(abi) to ruby-libs.
- ruby-1.8.4-64bit-pack.patch: backport patch from upstream to fix unpack("l")
  not working on 64bit arch and integer overflow on template "w". (#189350)
- updated License tag to be more comfortable, and with a pointer to get more
  details, like Python package does. (#179933)
- clean up.

---------------------------------------------------------------------
This update can be downloaded from:
    http://download.fedora.redhat.com/pub/fedora/linux/core/updates/5/

bfd62e1941d9b02ae45115081914ab6b817ad325  SRPMS/ruby-1.8.4-6.fc5.src.rpm
bfd62e1941d9b02ae45115081914ab6b817ad325  noarch/ruby-1.8.4-6.fc5.src.rpm
08d516672e356f9cfc84c3f12e4bd2b1c3145bf4  ppc/ruby-1.8.4-6.fc5.ppc.rpm
267eee593d04f5c5b73036bae6b504883ed9a37f  ppc/ruby-tcltk-1.8.4-6.fc5.ppc.rpm
83f50b18843eb41eb20ef083b0988a4d68d74b9f  ppc/ruby-ri-1.8.4-6.fc5.ppc.rpm
fc71264fcd92a78305c69a453f04df3692b4fabd  ppc/debug/ruby-debuginfo-1.8.4-6.fc5.ppc.rpm
562dc7d5d61f71c98c0898767877d7425e1fc2bb  ppc/ruby-docs-1.8.4-6.fc5.ppc.rpm
f63b55b45b389bdb29dbd6e0901f87bfac3d9de9  ppc/ruby-devel-1.8.4-6.fc5.ppc.rpm
586a5bf88410e671fff8459133f977b6619d90e6  ppc/ruby-libs-1.8.4-6.fc5.ppc.rpm
8879da76ff720a6181fb6fe762e36e3ca41b35c2  ppc/ruby-rdoc-1.8.4-6.fc5.ppc.rpm
4638931410c91d0d63ed28b3a7c7dfb0dd48f6f6  ppc/ruby-irb-1.8.4-6.fc5.ppc.rpm
73d1639580a05f047cc46e3a9b43518ea984bc84  ppc/ruby-mode-1.8.4-6.fc5.ppc.rpm
17192fa17d0e73f096df53321a9f723b8488f456  x86_64/debug/ruby-debuginfo-1.8.4-6.fc5.x86_64.rpm
024c85e460d19835c9e79f2afc4b985ce677b314  x86_64/ruby-docs-1.8.4-6.fc5.x86_64.rpm
60714a6a471410f8ef31ded16ec27f2434f4c2c3  x86_64/ruby-mode-1.8.4-6.fc5.x86_64.rpm
c1529eaabe4f76b2154994c56cd295b0fbc01a21  x86_64/ruby-ri-1.8.4-6.fc5.x86_64.rpm
2b0eb33f1a19386c37252b7507d3c211785f70ec  x86_64/ruby-1.8.4-6.fc5.x86_64.rpm
f1c05acd10b88bc0ca2f7df67687bb4c981a5e5b  x86_64/ruby-devel-1.8.4-6.fc5.x86_64.rpm
076b35b053a221b956060b3193e8058de2179695  x86_64/ruby-irb-1.8.4-6.fc5.x86_64.rpm
177ae56d5ce6940f22bb64300bb38f04a0554ce5  x86_64/ruby-rdoc-1.8.4-6.fc5.x86_64.rpm
cfc16eb3d61453f64bc5070f88790b86be223b95  x86_64/ruby-tcltk-1.8.4-6.fc5.x86_64.rpm
8ab9863803476aa33d6d46c1a15fd4c370b94147  x86_64/ruby-libs-1.8.4-6.fc5.x86_64.rpm
bae03715309e7027240672e37c5b037c4b704310  i386/ruby-docs-1.8.4-6.fc5.i386.rpm
dd0cbae642ae4245573a5e8a24f753f936347df1  i386/ruby-devel-1.8.4-6.fc5.i386.rpm
be57f80cde3c456a2a8390f5003d6c2cd58d5c98  i386/ruby-ri-1.8.4-6.fc5.i386.rpm
5525db387472df985fbb4b0e56aefa5d1b738205  i386/ruby-tcltk-1.8.4-6.fc5.i386.rpm
7498af44e503617be5ebc19f6f694788399b7114  i386/ruby-irb-1.8.4-6.fc5.i386.rpm
295eb2ca67849014862c23e1533a1ec48de943ce  i386/ruby-rdoc-1.8.4-6.fc5.i386.rpm
d57c9b8991efe32f9f931c0f60810196af1f45b7  i386/ruby-mode-1.8.4-6.fc5.i386.rpm
74c9481a21c3cb97cb7c2bf40fa83b4a85f1ddc1  i386/ruby-libs-1.8.4-6.fc5.i386.rpm
88a529248bbda5d837755a6826907712e74b3516  i386/ruby-1.8.4-6.fc5.i386.rpm
155a75687369dbc9bea83c7a0e1d1b49ea9296fa  i386/debug/ruby-debuginfo-1.8.4-6.fc5.i386.rpm

This update can be installed with the 'yum' update program.  Use 'yum update
package-name' at the command line.  For more information, refer to 'Managing
Software with yum,' available at http://fedora.redhat.com/docs/yum/.
---------------------------------------------------------------------


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]