[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[SECURITY] Fedora 9 Update: ruby-1.8.6.230-1.fc9



--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2008-5664
2008-06-25 00:43:26
--------------------------------------------------------------------------------

Name        : ruby
Product     : Fedora 9
Version     : 1.8.6.230
Release     : 1.fc9
URL         : http://www.ruby-lang.org/
Summary     : An interpreter of object-oriented scripting language
Description :
Ruby is the interpreted scripting language for quick and easy
object-oriented programming.  It has many features to process text
files and to do system management tasks (as in Perl).  It is simple,
straight-forward, and extensible.

--------------------------------------------------------------------------------
ChangeLog:

* Tue Jun 24 2008 Akira TAGOH <tagoh redhat com> - 1.8.6.230-1
- New upstream release.
- Security fixes. (#452294).
  - CVE-2008-1891: WEBrick CGI source disclosure.
  - CVE-2008-2662: Integer overflow in rb_str_buf_append().
  - CVE-2008-2663: Integer overflow in rb_ary_store().
  - CVE-2008-2664: Unsafe use of alloca in rb_str_format().
  - CVE-2008-2725: Integer overflow in rb_ary_splice().
  - CVE-2008-2726: Integer overflow in rb_ary_splice().
- ruby-1.8.6.111-CVE-2007-5162.patch: removed.
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #450825 - CVE-2008-2663 ruby: Integer overflows in rb_ary_store()
        https://bugzilla.redhat.com/show_bug.cgi?id=450825
  [ 2 ] Bug #443829 - CVE-2008-1891 ruby: WEBrick CGI source disclosure
        https://bugzilla.redhat.com/show_bug.cgi?id=443829
  [ 3 ] Bug #451821 - CVE-2008-2725 ruby: integer overflow in rb_ary_splice() (ruby-1.8.x) - REALLOC_N
        https://bugzilla.redhat.com/show_bug.cgi?id=451821
  [ 4 ] Bug #450821 - CVE-2008-2662 ruby: Integer overflows in rb_str_buf_append()
        https://bugzilla.redhat.com/show_bug.cgi?id=450821
  [ 5 ] Bug #451828 - CVE-2008-2726 ruby: integer overflow in rb_ary_splice() (ruby-1.8.x) - beg + rlen
        https://bugzilla.redhat.com/show_bug.cgi?id=451828
  [ 6 ] Bug #450834 - CVE-2008-2664 ruby: Unsafe use of alloca in rb_str_format()
        https://bugzilla.redhat.com/show_bug.cgi?id=450834
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update ruby' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on the
GPG keys used by the Fedora Project can be found at
http://fedoraproject.org/keys
--------------------------------------------------------------------------------


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]