[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[SECURITY] Fedora 8 Update: phpMyAdmin-2.11.8.1-1.fc8



--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2008-6810
2008-07-30 18:05:36
--------------------------------------------------------------------------------

Name        : phpMyAdmin
Product     : Fedora 8
Version     : 2.11.8.1
Release     : 1.fc8
URL         : http://www.phpmyadmin.net/
Summary     : Web based MySQL browser written in php
Description :
phpMyAdmin is a tool written in PHP intended to handle the administration of
MySQL over the Web. Currently it can create and drop databases,
create/drop/alter tables, delete/edit/add fields, execute any SQL statement,
manage keys on fields, manage privileges,export data into various formats and
is available in 50 languages

--------------------------------------------------------------------------------
Update Information:

This update solves PMASA-2008-6 (phpMyAdmin security announcement) from
2008-07-28: Cross-site Framing; XSS in setup.php; see
http://www.phpmyadmin.net/home_page/security.php?issue=PMASA-2008-6    -
[interface] Table list pagination in navi  - [profiling] Profiling causes query
to be executed again (really causes a problem in case of INSERT/UPDATE)  -
[import] SQL file import very slow on Windows  - [XHTML] problem with tabindex
and radio fields  - [interface] tabindex not set correctly  - [views] VIEW name
created via the GUI was not protected with backquotes  - [interface] Deleting
multiple views (space in name)  - [parser] SQL parser removes essential space  -
[export] CSV for MS Excel incorrect escaping of double quotes  - [interface]
Font size option problem when no config file  - [relation] Relationship view
should check for changes  - [history] Do not save too big queries in history  -
[security] Do not show version info on login screen  - [import] Potential data
loss on import resubmit  - [export] Safari and timedate  - [import, export]
Import/Export fails because of Mac files  - [security] protection against cross-
frame scripting and new directive AllowThirdPartyFraming  - [security] possible
XSS during setup  - [interface] revert language changing problem introduced with
2.11.7.1    phpMyAdmin 2.11.8.1 is a bugfix-only version containing normal bug
fixes and two security fixes. This version is identical to 2.11.8, except it
includes a fix for a notice about "lang".
--------------------------------------------------------------------------------
ChangeLog:

* Mon Jul 28 2008 Robert Scheck <robert fedoraproject org> 2.11.8.1-1
- Upstream released 2.11.8.1 (#456637, #456950)
* Mon Jul 28 2008 Robert Scheck <robert fedoraproject org> 2.11.8-1
- Upstream released 2.11.8 (#456637)
* Tue Jul 15 2008 Robert Scheck <robert fedoraproject org> 2.11.7.1-1
- Upstream released 2.11.7.1 (#455520)
* Mon Jun 23 2008 Robert Scheck <robert fedoraproject org> 2.11.7-1
- Upstream released 2.11.7 (#452497)
* Tue Apr 29 2008 Robert Scheck <robert fedoraproject org> 2.11.6-1
- Upstream released 2.11.6
* Tue Apr 22 2008 Robert Scheck <robert fedoraproject org> 2.11.5.2-1
- Upstream released 2.11.5.2 (#443683)
* Sat Mar 29 2008 Robert Scheck <robert fedoraproject org> 2.11.5.1-1
- Upstream released 2.11.5.1
* Mon Mar  3 2008 Robert Scheck <robert fedoraproject org> 2.11.5-1
- Upstream released 2.11.5
* Sun Jan 13 2008 Robert Scheck <robert fedoraproject org> 2.11.4-1
- Upstream released 2.11.4
- Corrected mod_security example in configuration file (#427119)
* Sun Dec  9 2007 Robert Scheck <robert fedoraproject org> 2.11.3-1
- Upstream released 2.11.3
- Removed the RPM scriptlets doing httpd restarts (#227025)
- Patched an information disclosure known as CVE-2007-0095 (#221694)
- Provide virtual phpmyadmin package and a httpd alias (#231431)
* Wed Nov 21 2007 Robert Scheck <robert fedoraproject org> 2.11.2.2-1
- Upstream released 2.11.2.2 (#393771)
* Tue Nov 20 2007 Mike McGrath <mmcgrath redhat com> 2.11.2.1-1
- Upstream released new version
* Mon Oct 29 2007 Mike McGrath <mmcgrath redhat com> 2.11.2-1
* upstream released new version
* Mon Oct 22 2007 Mike McGrath <mmcgrath redhat com> 2.11.1.2-1
* upstream released new version
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #456637 - phpMyAdmin: Cross-frame scripting and possible XSS during setup
        https://bugzilla.redhat.com/show_bug.cgi?id=456637
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update phpMyAdmin' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on the
GPG keys used by the Fedora Project can be found at
http://fedoraproject.org/keys
--------------------------------------------------------------------------------


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]