[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Fedora 9 Update: php-pear-PHP-CompatInfo-1.7.0-1.fc9



--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2008-3785
2008-05-17 19:21:35
--------------------------------------------------------------------------------

Name        : php-pear-PHP-CompatInfo
Product     : Fedora 9
Version     : 1.7.0
Release     : 1.fc9
URL         : http://pear.php.net/package/PHP_CompatInfo
Summary     : Find out version and extensions required for a piece of code to run
Description :
PHP_CompatInfo will parse a file/folder/script/array to find out the
minimum version and extensions required for it to run. Features advanced
debug output which shows which functions require which version and CLI
output script

--------------------------------------------------------------------------------
Update Information:

Upstream Changelog:    Here are a summary of all changes since API 1.6.0.    All
SAPI:  =========  * news  - add 3 options: ignore_functions_match,
ignore_extensions_match, ignore_constants_match.  - separate constants and
tokens in results    * changes  - full support of regular expressions for
"ignore_dirs" and "ignore_files" options.  - all reports display now the max
version information when needed.    * bugs  - User functions are not ignored  -
Parser ignore class-method that are named as standard php functions  - Standard
test suite failed under *nix    CLI only:  =========  * news  - Add new
--output-level switch to customize (all) reports output.  - Add new --summarize
switch to limit output to first line (summary) when parsing directory.  - Add
new --version switch to print version number of PHP_CompatInfo package.  - Add
--filter-ext switch to filter file extension when parsing directory  - Add new
column C to indicate a level of conditional code used (0: none,  1:
function_exists() used, 2: extension_loaded() used, 4: defined() used)    *
changes  - XML report structure change.  Render is improve if
PEAR::XML_Beautifier is available.  - pci.php file was rename to pci (without
extension) to match unix command syntax  - Text report is now really limited to
80 columns in all situation  - All switchs that accept option file parameter
allow now  to put line in comment with ; character (as in php.ini)    * QA  -
dependencies Console_Table, Console_GetArgs, XML_Util  are defined as required
and no more optional. CLI is a standard feature and should not be considered as
optional.
--------------------------------------------------------------------------------
ChangeLog:

* Fri Apr 18 2008 Remi Collet <Fedora FamilleCollet com> 1.7.0-1
- update to 1.7.0
- new Requires File_Find and XML_Beautifier
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update php-pear-PHP-CompatInfo' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on the
GPG keys used by the Fedora Project can be found at
http://fedoraproject.org/keys
--------------------------------------------------------------------------------


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]