[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[SECURITY] Fedora 9 Update: ipsec-tools-0.7.1-5.fc9



--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2008-9007
2008-11-07 01:32:59
--------------------------------------------------------------------------------

Name        : ipsec-tools
Product     : Fedora 9
Version     : 0.7.1
Release     : 5.fc9
URL         : http://ipsec-tools.sourceforge.net/
Summary     : Tools for configuring and using IPSEC
Description :
This is the IPsec-Tools package.  You need this package in order to
really use the IPsec functionality in the linux-2.5+ kernels.  This
package builds:

	- setkey, a program to directly manipulate policies and SAs
	- racoon, an IKEv1 keying daemon

--------------------------------------------------------------------------------
Update Information:

The update fixes memory leaks potentially leading to DoS (CVE-2008-3651
CVE-2008-3652).  It also fixes problems with DPD and NAT-T support.
--------------------------------------------------------------------------------
ChangeLog:

* Fri Oct 17 2008 Tomas Mraz <tmraz redhat com> - 0.7.1-5
- fix CVE-2008-3652 (memory leak DoS)
- compile racoon as PIE
- another fix for teardown of the IPSEC SAs on DPD in some circumstances
* Sun Aug 10 2008 Tomas Mraz <tmraz redhat com> - 0.7.1-4
- Even better fix for IPSEC SA purging avoiding code duplication
  (original idea by Darrel Goeddel)
* Fri Aug  8 2008 Tomas Mraz <tmraz redhat com> - 0.7.1-3
- Fix IPSEC SA purge with NAT_T enabled
* Wed Jul 30 2008 Tomas Mraz <tmraz redhat com> - 0.7.1-2
- Different approach to allow racoon to add loopback SAs for
  labeled IPSec (without ISAKMP)
* Tue Jul 29 2008 Tomas Mraz <tmraz redhat com> - 0.7.1-1
- Update to a new upstream version
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #456660 - CVE-2008-3651 ipsec-tools: racoon memory leak caused by invalid proposals
        https://bugzilla.redhat.com/show_bug.cgi?id=456660
  [ 2 ] Bug #458846 - CVE-2008-3652 ipsec-tools: racoon orphaned ph1s memory leak
        https://bugzilla.redhat.com/show_bug.cgi?id=458846
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update ipsec-tools' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on the
GPG keys used by the Fedora Project can be found at
http://fedoraproject.org/keys
--------------------------------------------------------------------------------


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]