[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Fedora 9 Update: kdebindings-4.1.0-5.fc9



--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2008-6743
2008-09-05 11:02:16
--------------------------------------------------------------------------------

Name        : kdebindings
Product     : Fedora 9
Version     : 4.1.0
Release     : 5.fc9
URL         : http://developer.kde.org/language-bindings/
Summary     : KDE bindings to non-C++ languages
Description :
KDE bindings to non-C++ languages

--------------------------------------------------------------------------------
Update Information:

This is an update to KDE 4.1.0.    See also:
http://www.kde.org/announcements/4.1/    It also updates Qt to 4.4.1 and PyQt4
to 4.4.2. Phonon is now a separate package (split out of kdelibs), QtWebKit is
now part of qt. In addition, the new qgtkstyle package provides a Qt 4 style
using GTK+ for drawing, providing better integration of Qt 4 and KDE 4
applications into GNOME.    NOTE: This update does not include kdepim-4.1.0.
NOTE: Users of previous KDE 4.1.0 packages from updates-testing should "yum
install phonon-backend-xine" which is now the default Phonon backend again.
(When upgrading from KDE 4.0.x, yum will pick the right one by default.)
--------------------------------------------------------------------------------
ChangeLog:

* Mon Jul 28 2008 Than Ngo <than redhat com> -  4.1.0-5
- respun
- get rid of kdebindings-4.1.0-kde#167450.patch that is included in new upstream
* Sat Jul 26 2008 Rex Dieter <rdieter fedoraproject org> 4.1.0-4.1
- BR: qscintilla-devel >= 2.2
* Fri Jul 25 2008 Kevin Kofler <Kevin tigcc ticalc org> 4.1.0-4
- fix Python and Ruby bindings overwriting each other (#456722, kde#167450)
* Fri Jul 25 2008 Kevin Kofler <Kevin tigcc ticalc org> 4.1.0-3
- drop unneeded BR kdegraphics4-devel (Ruby Okular bindings disabled by default)
- add BR kdepimlibs-devel for Python Akonadi bindings
* Fri Jul 25 2008 Than Ngo <than redhat com> 4.1.0-2
- respun
* Wed Jul 23 2008 Than Ngo <than redhat com> 4.1.0-1
- 4.1.0
* Fri Jul 18 2008 Rex Dieter <rdieter fedoraproject org> 4.0.99-1
- 4.0.99
* Mon Jul 14 2008 Rex Dieter <rdieter fedoraproject org> 4.0.98-3
- re-enable smoke (patched), ruby
* Mon Jul 14 2008 Rex Dieter <rdieter fedoraproject org> 4.0.98-2
- omit smoke, ruby bindings (build failures, sorting out upstream)
- -devel: -BR: PyQt4-devel
* Fri Jul 11 2008 Rex Dieter <rdieter fedoraproject org> 4.0.98-1
- 4.0.98
* Sun Jul  6 2008 Rex Dieter <rdieter fedoraproject org> 4.0.85-1
- 4.0.85
* Sat Jun 28 2008 Kevin Kofler <Kevin tigcc ticalc org> 4.0.84-2
- fix Python bindings for Phonon and Soprano
* Fri Jun 27 2008 Rex Dieter <rdieter fedoraproject org> 4.0.84-1
- 4.0.84
* Sat Jun 21 2008 Kevin Kofler <Kevin tigcc ticalc org> 4.0.83-4
- fix PyKDE4-devel to require PyKDE4 rather than itself
* Sat Jun 21 2008 Kevin Kofler <Kevin tigcc ticalc org> 4.0.83-3
- reenable Ruby again
- add missing Epoch for minimum kdegraphics-devel version requirement
- fix CMake target name conflict between Ruby and Python bindings
- fix file list for Ruby
* Fri Jun 20 2008 Kevin Kofler <Kevin tigcc ticalc org> 4.0.83-2
- reenable smoke again (keep ruby off for now)
- drop explicit ENABLE_SMOKEKDEVPLATFORM=OFF (now off by default)
- add BR kdegraphics-devel for the Smoke Okular bindings
- fix file list
* Thu Jun 19 2008 Than Ngo <than redhat com> 4.0.83-1
- 4.0.83 (beta2)
* Wed Jun 18 2008 Rex Dieter <rdieter fedoraproject org> 4.0.82-3
- revert, more borkage.
* Tue Jun 17 2008 Kevin Kofler <Kevin tigcc ticalc org> 4.0.82-2
- reenable smoke and ruby, set ENABLE_SMOKEKDEVPLATFORM=OFF (no kdevplatform)
* Sun Jun 15 2008 Rex Dieter <rdieter fedoraproject org> 4.0.82-1
- 4.0.82
- omit ruby, smoke (busted) => no -devel subpkg (for now)
- PyKDE4(-devel) subpkgs
* Tue May 27 2008 Kevin Kofler <Kevin tigcc ticalc org> 4.0.80-2
- disable php-qt for now
- apply PyKDE4 and smokekde build fixes from upstream
- update file lists (comment out smokeplasma, add new smoke/ruby files)
- fix incorrect libdir on lib64 platforms
* Mon May 26 2008 Than Ngo <than redhat com> 4.0.80-1
- 4.1 beta1
* Wed May  7 2008 Kevin Kofler <Kevin tigcc ticalc org> 4.0.72-1
- update to 4.0.72
- add BR soprano-devel
- update file list to include plasma-ruby stuff
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #457526 - Konqueror, Kopete don't fully terminate in KDE 4.1
        https://bugzilla.redhat.com/show_bug.cgi?id=457526
  [ 2 ] Bug #456820 - Plasma crash when installing a new Plasma Theme
        https://bugzilla.redhat.com/show_bug.cgi?id=456820
  [ 3 ] Bug #454930 - Qt Assistant for Qt4 opens a blank window
        https://bugzilla.redhat.com/show_bug.cgi?id=454930
  [ 4 ] Bug #454458 - Translation for KPovModeler shouldn't be there
        https://bugzilla.redhat.com/show_bug.cgi?id=454458
  [ 5 ] Bug #456827 - dolphin doesn't work (soprano version mismatch)
        https://bugzilla.redhat.com/show_bug.cgi?id=456827
  [ 6 ] Bug #456797 - file conflict between kde-l10n-4.1.0-1.fc9.1 and libkdcraw-0.1.4-2.fc9
        https://bugzilla.redhat.com/show_bug.cgi?id=456797
  [ 7 ] Bug #456850 - Missing dep: Package-error in updates-testing?
        https://bugzilla.redhat.com/show_bug.cgi?id=456850
  [ 8 ] Bug #440226 - crash when "samba" button clicked
        https://bugzilla.redhat.com/show_bug.cgi?id=440226
  [ 9 ] Bug #455623 - Cannot install KDM Themes
        https://bugzilla.redhat.com/show_bug.cgi?id=455623
  [ 10 ] Bug #440031 - icons in tray change to few squares
        https://bugzilla.redhat.com/show_bug.cgi?id=440031
  [ 11 ] Bug #453321 - Login manager missing directory complaints
        https://bugzilla.redhat.com/show_bug.cgi?id=453321
  [ 12 ] Bug #457479 - "Run as root" dialog of kdm system settings is shown twice
        https://bugzilla.redhat.com/show_bug.cgi?id=457479
  [ 13 ] Bug #457739 - systemsettings entry is missing from classic program menu
        https://bugzilla.redhat.com/show_bug.cgi?id=457739
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update kdebindings' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on the
GPG keys used by the Fedora Project can be found at
http://fedoraproject.org/keys
--------------------------------------------------------------------------------


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]