[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Fedora 11 Update: python-peak-rules-0.5a1.dev-8.2582.fc11



--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2009-7792
2009-07-19 03:26:55
--------------------------------------------------------------------------------

Name        : python-peak-rules
Product     : Fedora 11
Version     : 0.5a1.dev
Release     : 8.2582.fc11
URL         : http://pypi.python.org/pypi/PEAK-Rules
Summary     : Generic functions and business rules support systems
Description :
PEAK-Rules is a highly-extensible framework for creating and using generic
functions, from the very simple to the very complex.  Out of the box, it
supports multiple-dispatch on positional arguments using tuples of types,
full predicate dispatch using strings containing Python expressions, and
CLOS-like method combining.  (But the framework allows you to mix and match
dispatch engines and custom method combinations, if you need or want to.)

--------------------------------------------------------------------------------
Update Information:

Fix deprecation warnings from most peak-rules directives as well as x86_64
doctest fixes only in devel.
--------------------------------------------------------------------------------
ChangeLog:

* Tue Jul 14 2009 Kyle VanderBeek <kylev kylev com> - 0.5a1.dev-8.2582
- SVN r2600 to fix python 2.6 deprecation warnings from BitmapIndex
* Wed Jun  3 2009 Luke Macken <lmacken redhat com> 0.5a1.dev-7.2582
- Add a patch to get the doctests to work on x86_64
* Wed Apr 15 2009 Karsten Hopp <karsten redhat com> 0.5a1.dev-6.2582
- Disable checks on s390x for now, see bugzilla #495874
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #511401 - Most peak-rules directives throw DeprecationWarning under python >= 2.6
        https://bugzilla.redhat.com/show_bug.cgi?id=511401
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update python-peak-rules' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on the
GPG keys used by the Fedora Project can be found at
http://fedoraproject.org/keys
--------------------------------------------------------------------------------


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]