[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[SECURITY] Fedora 9 Update: poppler-0.8.7-2.fc9



--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2009-6982
2009-06-27 01:16:02
--------------------------------------------------------------------------------

Name        : poppler
Product     : Fedora 9
Version     : 0.8.7
Release     : 2.fc9
URL         : http://poppler.freedesktop.org/
Summary     : PDF rendering library
Description :
Poppler, a PDF rendering library, is a fork of the xpdf PDF
viewer developed by Derek Noonburg of Glyph and Cog, LLC.

--------------------------------------------------------------------------------
Update Information:

An update to address jbig2-related security issues.
--------------------------------------------------------------------------------
ChangeLog:

* Fri Jan 23 2009 Rex Dieter <rdieter fedoraproject org> - 0.8.7-2
- use backported jbig2_security patch from debian/ubuntu (#496943)
- poppler-data-0.2.1
- --enable-libjpeg (speed)
- track sonames
- patch to workaround okular rendering hyperlinks (#480357)
* Wed Oct  8 2008 Rex Dieter <rdieter fedoraproject org> - 0.8.7-1
- 0.8.7, fixes "Saving a PDF ... results in mangled file" (#462481)
- spec cosmetics from devel/ branch
* Thu Jul 31 2008 Tomas Hoger <thoger redhat com> - 0.8.1-2
- Security update:
  Add upstream patch for CVE-2008-2950 / oCERT-2008-007 - use of
  an uninitilized pointer to call free() in Page::~Page (#454277)
- Bug fixes:
  Fix crash when reading QuadPoints (#448516)
  Use static FT_Library in CairoOutputDev, as dynamic may trigger
  use-after-free and crash e.g. evince (#456867)
* Mon Apr 28 2008 Matthias Clasen <mclasen redhat com> - 0.8.1-1
- Update to 0.8.1
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #496943 - CVE-2009-0146 CVE-2009-0147 CVE-2009-0166 CVE-2009-0799 CVE-2009-0800 CVE-2009-1179 CVE-2009-1180 CVE-2009-1181 CVE-2009-1182 CVE-2009-1183 CVE-2009-1187 CVE-2009-1188 poppler various flaws [F9]
        https://bugzilla.redhat.com/show_bug.cgi?id=496943
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update poppler' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on the
GPG keys used by the Fedora Project can be found at
http://fedoraproject.org/keys
--------------------------------------------------------------------------------


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]