[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[SECURITY] Fedora 11 Update: jetty-5.1.15-4.fc11



--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2009-5509
2009-05-26 06:21:24
--------------------------------------------------------------------------------

Name        : jetty
Product     : Fedora 11
Version     : 5.1.15
Release     : 4.fc11
URL         : http://jetty.mortbay.org/jetty/
Summary     : The Jetty Webserver and Servlet Container
Description :
Jetty is a 100% Java HTTP Server and Servlet Container.
This means that you do not need to configure and run a
separate web server (like Apache) in order to use java,
servlets and JSPs to generate dynamic content. Jetty is
a fully featured web server for static and dynamic content.
Unlike separate server/container solutions, this means
that your web server and web application run in the same
process, without interconnection overheads and complications.
Furthermore, as a pure java component, Jetty can be simply
included in your application for demonstration, distribution
or deployment. Jetty is available on all Java supported
platforms.

--------------------------------------------------------------------------------
Update Information:

This build upgrades jetty to 5.1.15 which addresses CVE-2009-1523.
--------------------------------------------------------------------------------
ChangeLog:

* Fri May 22 2009 Jeff Johnston <jjohnstn redhat com> 5.1.15-4
- Update sources file.
* Thu May 21 2009 Jeff Johnston <jjohnstn redhat com> 5.1.15-3
- Do not allow directory listings.
* Tue May 19 2009 Jeff Johnston <jjohnstn redhat com> 5.1.15-2
- Update OSGI manifest file.
* Tue May 19 2009 Jeff Johnston <jjohnstn redhat com> 5.1.15-1
- Upgrade to 5.1.15 source tarball for Fedora.
* Wed Apr 22 2009 Jeff Johnston <jjohnstn redhat com> 5.1.14-3
- Add %{libdir} to files list.
- Resolves #473585
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #499867 - CVE-2009-1523 CVE-2009-1524: multiple vulnerabilities in jetty
        https://bugzilla.redhat.com/show_bug.cgi?id=499867
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update jetty' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on the
GPG keys used by the Fedora Project can be found at
http://fedoraproject.org/keys
--------------------------------------------------------------------------------


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]