[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Fedora 11 Update: vim-perl-support-4.2-1.fc11



--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2009-5148
2009-05-19 00:08:00
--------------------------------------------------------------------------------

Name        : vim-perl-support
Product     : Fedora 11
Version     : 4.2
Release     : 1.fc11
URL         : http://www.vim.org/scripts/script.php?script_id=556
Summary     : Perl-IDE for VIM
Description :
Perl Support implements a Perl-IDE for Vim/gVim. It is written to considerably
speed up writing code in a consistent style.  This is done by inserting
complete statements, comments, idioms, code snippets, templates, and POD
documentation.  Reading perldoc is integrated.  Syntax checking, running a
script, running perltidy,  running perlcritics, starting a debugger and a
profiler can be done with a keystroke.

--------------------------------------------------------------------------------
Update Information:

This update to the latest version of perl-support includes:  - Regex Analyser
extended: check several regular expressions against several targets.  - Regex
Analyser extended: regular expressions with  match-time code evaluation
possible.  - Regex Analyser extended: g-modifier allowed; all matches will be
shown.  - Regex Analyser extended: qr/.../ can be picked up.  - Comments menu:
adjustment of end-of-line comments improved.  - Statements menu: else block (key
mapping \se).  - Regex menu: new special variables (Perl 5.10)  - Templates:
handling of <SPLIT> improved.  - Bugfix (Windows only): templates will be loaded
twice, generating a long list of error messages.  - Bugfix: Perl::Tags
integration not working.  - Minor improvements and bugfixes.
--------------------------------------------------------------------------------
ChangeLog:

* Fri May  8 2009 Iain Arnell <iarnell gmail com> 4.2-1
- update to 4.2
* Thu Apr 30 2009 Iain Arnell <iarnell gmail com> 4.1-3
- require Devel::FastProf and Perl::Tags
- use global macro, not define
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update vim-perl-support' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on the
GPG keys used by the Fedora Project can be found at
http://fedoraproject.org/keys
--------------------------------------------------------------------------------


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]