[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[SECURITY] Fedora 11 Update: kdebindings-4.3.1-3.fc11



--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2009-9397
2009-09-09 00:46:12
--------------------------------------------------------------------------------

Name        : kdebindings
Product     : Fedora 11
Version     : 4.3.1
Release     : 3.fc11
URL         : http://developer.kde.org/language-bindings/
Summary     : KDE bindings to non-C++ languages
Description :
KDE bindings to non-C++ languages

--------------------------------------------------------------------------------
Update Information:

This updates KDE to 4.3.1, the latest upstream bugfix release. The main
improvements are:  * KDE 4.3 is now also available in Croatian.  * A crash when
editing toolbar setup has been fixed.  * Support for transferring files through
SSH using KIO::Fish has been fixed.  * A number of bugs in KWin, KDE's window
and compositing manager has been fixed.  * A large number of bugs in KMail,
KDE's email client are now gone.    See
http://kde.org/announcements/announce-4.3.1.php for more information.    In
addition, this update:  * fixes a potential security issue (CVE-2009-2702) with
certificate validation in the KIO KSSL code. It is believed that the affected
code is not actually used (the code in Qt, for which a security update was
already issued, is) and thus the issue is only potential, but KSSL is being
patched just in case,  * splits PolicyKit-kde out of kdebase-workspace again to
avoid forcing it onto GNOME-based setups, where PolicyKit-gnome is desired
instead (#519654).
--------------------------------------------------------------------------------
ChangeLog:

* Thu Sep  3 2009 Kevin Kofler <Kevin tigcc ticalc org> - 4.3.1-3
- also disable polkit-qt on EL6+
- also remove polkit-qt sip files and examples on F12+/EL6+
* Thu Sep  3 2009 Kevin Kofler <Kevin tigcc ticalc org> - 4.3.1-2
- only (temporarily) disable Falcon on F12+
- drop bindings for polkit-qt on F12+ (PolicyKit 0.9 is going away)
- remove unused (commented out) patch
* Fri Aug 28 2009 Than Ngo <than redhat com> - 4.3.1-1
- 4.3.1
- temporarily disable Falcon bindings (build fails with Falcon 0.9.x)
* Mon Aug 17 2009 Rex Dieter <rdieter fedoraproject org> - 4.3.0-5
- re-enable php bindings (rawhide)
* Tue Aug 11 2009 Rex Dieter <rdieter fedoraproject org> - 4.3.0-4.1
- BR: qscintilla-devel >= 2.4
* Sun Aug  9 2009 Rex Dieter <rdieter fedoraproject org> - 4.3.0-4
- manually specify PYTHON_LIBRARIES (and friends) (#516386)
* Mon Aug  3 2009 Than Ngo <than redhat com> - 4.3.0-3
- respin
* Sat Aug  1 2009 Rex Dieter <rdieter fedoraproject org> 4.3.0-2
- workaround pykdeuic4 upgrade brokenness (introduced in 4.2.98)
* Thu Jul 30 2009 Than Ngo <than redhat com> - 4.3.0-1
- 4.3.0
- more pykdeuic4 and related multilib love (kdebug#198162)
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng lists fedoraproject org> - 4.2.98-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
* Wed Jul 22 2009 Than Ngo <than redhat com> - 4.2.98-1
- 4.3rc3
* Mon Jul 20 2009 Than Ngo <than redhat com> - 4.2.96-5
- add correct check for php version
* Mon Jul 20 2009 Than Ngo <than redhat com> - 4.2.96-4
- allow for build php-5.2.x
* Mon Jul 20 2009 Than Ngo <than redhat com> - 4.2.96-3
- fix build issue with php-5.3.x
* Thu Jul 16 2009 Rex Dieter <rdieter fedoraproject org> - 4.2.96-2
- fix pykdeuic4-related install bits (kdebug#198162)
- pyqt4_version 4.5.2
- License: LGPLv2+
* Fri Jul 10 2009 Than Ngo <than redhat com> - 4.2.96-1
- 4.3rc2
* Fri Jun 26 2009 Than Ngo <than redhat com> - 4.2.95-1
- 4.3rc1
* Mon Jun 22 2009 Kevin Kofler <Kevin tigcc ticalc org> - 4.2.90-3
- make the Python plugin factory work without python-devel
* Wed Jun 17 2009 Rex Dieter <rdieter fedoraproject org> - 4.2.90-2
- rework old-PyQt4 patch
* Wed Jun  3 2009 Rex Dieter <rdieter fedoraproject org> - 4.2.90-1
- KDE-4.3 beta2 (4.2.90)
* Thu May 21 2009 Rex Dieter <rdieter fedoraproject org> - 4.2.85-2
- respin against PyQt-4.5
* Wed May 20 2009 Than Ngo <than redhat com> - 4.2.85-1
- 4.2.85 (4.3 beta1)
- build fixes backported from trunk by Nicolas L├ęcureuil <neoclust mandriva org>
- revert change which requires PyQt4 4.5 (Kevin Kofler)
- fix build issue with gcc-4.4
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #520661 - CVE-2009-2702 kdelibs: kssl incorrect verification of SSL certificate with NUL in subjectAltName
        https://bugzilla.redhat.com/show_bug.cgi?id=520661
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update kdebindings' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on the
GPG keys used by the Fedora Project can be found at
http://fedoraproject.org/keys
--------------------------------------------------------------------------------


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]