[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Fedora-packaging] sparse 0.2, headers and static lib



sparse 0.2 is out now, and includes header files and a static
libsparse.a, but doesn't include a libsparse.so.  Jeff Garzik in
particular requested the static lib and headers for a project he's
working on.

So, I added a -devel package and put in the header files and
sparse.pc.  I've also put libsparse.a in there, but see the proposal
for a -static package.

Questions:

1) need -devel have a Requires: %{name}-%{version}-${release} if that
doesn't include a shared library?  I wouldn't think so, but it's a
"Must" in the guidelines.

2) need I create a -static package for the static library?

3) if yes, should -static have a Requires:
   %{name}-devel-%{version}-%{release}?  Should this go in the
   recommendations for all -static packages?


Thanks,
Matt

-- 
Matt Domsch
Software Architect
Dell Linux Solutions linux.dell.com & www.dell.com/linux
Linux on Dell mailing lists @ http://lists.us.dell.com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]