[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Fedora-packaging] PHP packaging policy notes



chris stone gmail com ("Christopher Stone") writes:

> Packages which are .php files only such as php-Smarty or php-pear-Foo
> need only require php >= version they say they require, or if they do
> not say, then php >= current version (or no version) should be fine.
> I have some php-pear packages which specifically indicate they need
> php >= 4.2.0 some that say they need php >= 4.3.0.

Such Requires: do not make sense nowadays. The ability to require a
special program version was removed some time ago from rpm.

Now, you can require a special package version only and every PHP in
the supported Fedora Extras branches fulfills the requirements. Since
packaging guidelines are tending to minimize the explicitly written
(Build)Requires:, such unneeded versions should be removed too.



Enrico


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]