[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Fedora-packaging] Re: kernel module packaging



On 6/5/06, Tom 'spot' Callaway <tcallawa redhat com> wrote:

By documenting it as part of our standards, we're implying that it is
something with benefit to the packagers. Since there is no kernel ABI in
Fedora or upstream (remember, all kernel ABIs in RHEL are artificial
constructs), it does hurt packagers who are unaware of this fact. It
leads them to believe that they don't need to use the full Requires:
%{version}-%{release} in kernel-module addon packages, when they
absolutely do.

Well, they wouldn't necessarily include that Requires line, because
the kernel dependency is now against a set of binary checksums that
determine compatibility.

In fact, I'm not really calling for major packaging changes - by
making a few changes to kmodtool behind the scenes, all of this is
abstracted from the packager, who is free to demand a specific kernel
or just let the dependency resolution figure out if the kernel and
module will be compatible at RPM install time. The only issue really
is how this would affect official "policy" with regards to kernel
dependencies as you hinted at above.

Jon.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]