[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Fedora-packaging] Re: -devel arch dependencies



On Thu, 2007-04-12 at 10:52 -0400, Matthew Miller wrote:
> On Thu, Apr 12, 2007 at 09:19:41AM -0400, seth vidal wrote:
> > > > Matthias, still annoyed at "yum install gdb" trying to pull in almost an
> > > > entire "compat" 32bit system... yeah, "yum install gdb.x86_64" :-p
> > > Someday we'll convince Seth to come around on this. :)
> > And how do we go about explaining to users on x86_64 machines why they
> > have to jump through all these hoops to run firefox that'll work with
> > plugins?
> 
> yum install firefox.i386 ?
> 
> With the default being to match "bestarch" if none is given.
> 
> Okay, what am I missing? :)

FWIW, I'm still not sure why we don't do this:

x86_64 repo (with all x86_64 packages and firefox.i386 and deps as ONLY
i386 packages)
i386 repo (with all i386 packages)

x86_64 installs include yum config for i386 repo, but it is disabled by
default. You want multilib, enable the i386 repo.

I doubt that we have any statistics on people willingly using multilib,
but I know I got it on my x86_64 machine and I sure as hell didn't want
it for anything besides firefox.

~spot


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]