[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Bug 174795] mod_perl broken by perl-5.8.5-18.FC3 security update



Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug report.

Summary: mod_perl broken by perl-5.8.5-18.FC3 security update


https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=174795


jvdias redhat com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |ASSIGNED




------- Additional Comments From jvdias redhat com  2005-12-02 13:04 EST -------
Very sorry about this - yes, the ABI was inadvertently changed by the fix for
bug 140563 – 'Perl not properly supporting NPTL' .

Basically, without this fix anything that relies on the value returned by 
Perl_Ippid_ptr or of Perl_ppid is broken, as this value is invalid, since
the threads implementation uses nptl .
 
Unfortunately, as was found for RHEL-3, this change requires many packages that
rely on the PERL ABI to be rebuilt - see bug 142039 .

So I'm backing out the change (removal of -DTHREADS_HAVE_PIDS from the configure
command) and generating a new perl-5.8.5-20.FC3 update.

-- 
Configure bugmail: https://bugzilla.redhat.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]