[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Bug 225357] New: CPANPLUS needs Module::Pluggable for configuration



Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug report.




https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=225357

           Summary: CPANPLUS needs Module::Pluggable for configuration
           Product: Fedora Extras
           Version: fc6
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: normal
         Component: perl-CPANPLUS
        AssignedTo: steve silug org
        ReportedBy: ianburrell gmail com
         QAContact: extras-qa fedoraproject org
                CC: fedora-perl-devel-list redhat com


The current version (0.076-1) of perl-CPANPLUS needs Module::Pluggable for the
initial configuration.  After just installing perl-CPANPLUS, I get following
error message when running "cpanp".

Can't locate Module/Pluggable.pm in @INC (@INC contains: /root/.cpanplus/lib
/usr/lib/perl5/site
_perl/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi /usr/
lib/perl5/site_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.5/i386-linux-thre
ad-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7
/usr/lib/perl5/site_perl/
5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.8/i
386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi
/usr/lib/perl5/v
endor_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-mult
i /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7
/usr/lib/perl5/vendor_perl/5
.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl
/usr/lib/perl5/5.8.8/i386-linux
-thread-multi /usr/lib/perl5/5.8.8 .) at
/usr/lib/perl5/vendor_perl/5.8.8/CPANPLUS/Configure.pm 
line 135.
BEGIN failed--compilation aborted at /usr/bin/cpanp line 14.

It looks like Module::Pluggable is loaded dynamically which is why it isn't
included in the automatic requires list.  My impression is that this is only
needed for initial configuration.  If CPANPLUS is already configured, it works
fine.  Since Module::Pluggable is available in Extras, it would probably be best
to add an explicit Requires.

-- 
Configure bugmail: https://bugzilla.redhat.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]