[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Redundant/conflicting Perl Provides?



A look at Fedora 7 package Provides:

mrtg provides perl(SNMP_util) EQ 0 1.08
perl-SNMP_Session provides perl(SNMP_util) EQ 0 1.06
 required by: perl-SNMP_Session - 1.08-3.fc6.noarch

mrtg provides perl(SNMP_Session) EQ 0 1.08
perl-SNMP_Session provides perl(SNMP_Session) EQ 0 1.08
 required by: perl-SNMP_Session - 1.08-3.fc6.noarch
 required by: mrtg - 2.15.1-2.fc7.i386

mrtg provides perl(BER) EQ 0 1.05
perl-SNMP_Session provides perl(BER) EQ 0 1.05
 required by: perl-SNMP_Session - 1.08-3.fc6.noarch
 required by: mrtg - 2.15.1-2.fc7.i386

samba provides perl(smbldap_tools) EQ 0 1.00
smbldap-tools provides perl(smbldap_tools) EQ 0 1.00
 required by: smbldap-tools - 0.9.2-5.fc7.noarch

perl-Email-MIME provides perl(Email::MIME) EQ 0 1.859
perl-Email-MIME-Creator provides perl(Email::MIME)
 required by: bugzilla - 3.0-3.fc7.noarch
 required by: perl-Email-MIME-Attachment-Stripper - 1.313-2.fc7.noarch
 required by: perl-Email-MIME-Creator - 1.453-1.fc7.noarch
 required by: perl-Email-MIME-Modifier - 1.441-1.fc7.noarch
 required by: perl-Email-Reply - 1.201-3.fc7.noarch
 required by: bugzilla - 3.0-3.fc7.noarch
 required by: perl-Email-MIME-Attachment-Stripper - 1.313-2.fc7.noarch
 required by: perl-Email-MIME-Modifier - 1.441-1.fc7.noarch
 required by: perl-Email-Reply - 1.201-3.fc7.noarch

perl-Email-Simple provides perl(Email::Simple)
perl-Email-Simple-Creator provides perl(Email::Simple)
 required by: perl-Email-Abstract - 2.132-3.fc7.noarch
 required by: perl-Email-MIME - 1.859-1.fc7.noarch
 required by: perl-Email-Send - 2.185-2.fc7.noarch
 required by: perl-Email-Abstract - 2.132-3.fc7.noarch
 required by: perl-Email-MIME - 1.859-1.fc7.noarch
 required by: perl-Email-Send - 2.185-2.fc7.noarch

perl-Time-Piece provides perl(Time::Piece) EQ 0 1.09
perl-Time-Piece-MySQL provides perl(Time::Piece)
 required by: perl-Email-Date - 1.102-2.fc7.noarch
 required by: perl-Time-Piece-MySQL - 0.05-3.fc6.noarch
 required by: perl-Time-Piece-MySQL - 0.05-3.fc6.noarch
 required by: perl-Email-Date - 1.102-2.fc7.noarch

perl-Class-DBI-Loader provides perl(Class::DBI::Loader::Generic) EQ 0 0.30
perl-Class-DBI-Loader-Relationship provides perl(Class::DBI::Loader::Generic)
 required by: perl-Class-DBI-Loader - 0.33-1.fc6.noarch


Some of these may be redundant on purpose. But some look suspicious,
because multiple packages provide the same thing. For example, "mrtg"
provides something required by
"perl-SNMP_Session".

Comments anyone?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]