[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Bug 230608] missing config.h in latest -14



Ralf Corsepius <rc040203 freenet de> writes:

> On Mon, 2007-03-05 at 11:08 -0500, Robin Norwood wrote:

[...]

>> If we retroactively add a 'Provides: perl-devel' to versions of perl in
>> older distributions, will that help?
> It will solve the *.spec portability issue, but ... the core question
> still remains: Is this split "correct" and "sustainable" or simply
> broken?
>
> ATM, IMO, the outcome is still unclear.

Yes, I meant assuming we decide to 'go forward' with this change.

> E.g. wrt to the MakeMaker issue, the "correct solution" would be to let
> a ExtUtils::MakeMaker spec "Requires: perl-devel", and to let all
> perl-modules using ExtUtils::MakeMaker at build-time
> "BuildRequires: perl(ExtUtils::MakeMaker)".
>
> I had wanted to have deeper look into this problem throughout today, but
> haven't found the time for it (and my day is almost over).

This definitely needs more attention.

-RN

-- 
Robin Norwood
Red Hat, Inc.

"The Sage does nothing, yet nothing remains undone."
-Lao Tzu, Te Tao Ching


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]