[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Should perl-devel Obsolete perl?



On Tue, 2007-03-06 at 10:43 -0500, Robin Norwood wrote:
> Ralf Corsepius <rc040203 freenet de> writes:
> 
> > Hi,
> >
> > Another issue related to the perl-devel split out:
> >
> > The files having been contained in "perl < *-14", now are 
> > distributed through "perl+perl-devel"
> >
> > IMO, perl-devel >= *-14 therefore should 
> > Obsoletes: perl < 4:5.8.8-14
> > to guarantee an update/upgrade without functional regressions.
> >
> > Unfortunately: Such a change has dramatic effects on yum: It causes yum
> > to iterate through all perl(...) deps.
> 
> This doesn't seem right to me anyway.  perl-devel doesn't obsolete older
> versions of perl since it doesn't replace their functionality.
It does. 

Several perl(..) modules formerly having been contained in perl, in
future will be provided by perl-devel (e.g. perl(Extutils::MakeMaker)).

> perl+perl-devel does 'obsolete' older versions of perl, but rpm can't
> really express that.
It can - Let perl-devel:
Obsoletes: perl < 4:5.8.8-14


perl will provide "perl-4:5.8.8-14"
and
perl-devel will provide "perl-devel-4:5.8.8-14"

i.e. after and update the "obsoletes" won't have any influence any more.

Ralf




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]