[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC2 install with 'selinux' fails....



I was also faced with the question - to 'Clean Install' or not.

The pro consideration is that you have a completely known entity - no
configuration files that are hanging around from the last tests.

The con consideration is that you don't have old configuration (and other)
files that you can look at and compare with the newly installed image.

A compromise approach is to boot up another system, mount the fedora hard
disk on that system, and create a directory /old and then move all of the
directories in / to the /old directory (e.g. cd /; mv lib /old; mv usr
/old, etc) on the fedora disk (assumes at least two disks, or weird
partitions on one disk)

The install of Fedora2 assumes you have enough disk space. If not, you can
selectively delete directories in the /old directory.  Doing 'rm -rf
/old/lib' will cut the space required by the old system dramatically.

After all of the directories have been moved or copied (if /boot is on a
separate partition), then boot from FC2 install disk 1, format /boot and
leave all of the other partitions 'as is'. This should give you a 'clean'
FC2 system install.

There have been updates since the base FC2 iso images were made, so try to do

yum update \*

You may have trouble with ppp - in that case, do

yum --exclude=ppp update \*

Good luck - I'm still not completely up with selinux.

BobG

----

On Fri, 21 May 2004 19:29:35 -0400 Richard Hally wrote:
>t l wrote:
>> I tried to install my shiny new FC2 CDs (verified!) 'on top of' an existing
>> FC2T3/selinux=enabled system. I entered 'selinux' at the install/boot
>>prompt.
>>
>> I tried both 'updating existing system' and a clean install on top of the
>> existing partitions. After selecting packages and writing the install image
>> to disk, both attempt produce an anaconda abort message saying
>>      OSError: [Errno 17] File exists: '/mnt/sysimage/selinux'
>>
>> I bugzilla'ed this against anaconda as the abort message requested
>> (https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=123687), but
>> I'm guessing that I missed something quite basic.  Do I need to
>> completely wipe the drive clean to proceed?
>>
>> Suggestions warmly welcomed.
>>    tom
>>
>>
>I had the same problem. I went for a fresh install. One thing that may
>help is at the configure the firewall screen during the install, change
>the selinux option to 'warn'.
>HTH
>Richard Hally
>
>--
>fedora-selinux-list mailing list
>fedora-selinux-list redhat com
>http://www.redhat.com/mailman/listinfo/fedora-selinux-list


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]