[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: shared lib problem



Thanks for the info. 

Actually, it worked with texrel_shlib_t. Don't know if it is right
solution or not... 

I briefly read the site but still not sure what the real solution is.
I wonder if the error is pointing there's some fundamental bugs
lurk in my code. 
There are no writable variables in shared libraries but almost all
code have been written in C++. Is it affecting for some reason?
I had no problems with SELinux targeted policy in fc4.

Please enlighten me.

Thanks,
-- Junji

Mark Ennis wrote:
> See:
> http://people.redhat.com/drepper/selinux-mem.html
> http://people.redhat.com/drepper/dsohowto.pdf
> 
> On 2/9/06, Junji Kanemaru <linux linuon com> wrote:
> 
>>Hi,
>>
>>I'm having problem with fc5-test2 that my app fails to load its
>>own shared library. The error I'm getting is:
>>
>>"cannot restore segment prot after reloc: Permission denied"
>>
>>It only happens when /selinux/enforce is true. I changed
>>security context of the shared library but same... Any clue?
>>
>>If more info needed then let me know what kind of info are
>>needed.
>>
>>Thanks,
>>-- Junji
>>
>>--
>>Junji Kanemaru
>>Linuon Inc.
>>Tokyo Japan
>>
>>--
>>fedora-selinux-list mailing list
>>fedora-selinux-list redhat com
>>https://www.redhat.com/mailman/listinfo/fedora-selinux-list
>>
> 
> 

-- 
Junji Kanemaru
Linuon Inc.
Tokyo Japan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]