[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fedora 7 nvidia issues



>Hi, folks. I'm having a few issues with nvidia on a fresh install of F7.
>During startup I see messages that state that nvidia can't create:
>
>/dev/nvidia0
>/dev/nvidia1
>/dev/nvidia2
>/dev/nvidia3
>/dev/nvidiactl
>
>kmod-nvidia-96xx-1.0.9631-12.2.6.21_1.3194.fc7
>xorg-x11-drv-nvidia-96xx-1.0.9631-11.lvn7
>
>Here are the relevant avcs while running in permissive mode:
>
>Jun  1 12:48:17 chaucer kernel: audit(1180702076.657:2): policy loaded
>auid=4294967295
>Jun  1 12:48:17 chaucer kernel: audit(1180727282.123:3): avc:  denied
>{ getattr } for  pid=410 comm="cp" name="nvidia0" dev
>=sda2 ino=1944970 scontext=system_u:system_r:udev_t:s0-s0:c0.c1023
>tcontext=system_u:object_r:etc_t:s0 tclass=chr_file
>Jun  1 12:48:17 chaucer kernel: audit(1180727282.123:4): avc:  denied
>{ create } for  pid=410 comm="cp" name="nvidia0" scon
>text=system_u:system_r:udev_t:s0-s0:c0.c1023
>tcontext=system_u:object_r:etc_t:s0 tclass=chr_file
>Jun  1 12:48:17 chaucer kernel: audit(1180727282.123:5): avc:  denied
>{ setattr } for  pid=410 comm="cp" name="nvidia0" dev
>=tmpfs ino=1644 scontext=system_u:system_r:udev_t:s0-s0:c0.c1023
>tcontext=system_u:object_r:etc_t:s0 tclass=chr_file
>
>Thanks,
>
>Bob

Bob:

I had the same problem when I installed kmod-nvidia.  I'm not sure 
what caused the issues but right after I installed it I logged out 
and then logged in and it worked fine but gave me the same messages 
you got when I rebooted.  I uninstalled and rebooted and still had 
the error messages.  I thought it was a selinux issue so I relabled 
the whole disk.  Then I rebooted again and reinstalled kmod-nvidia 
then immediately rebooted again.  This time it worked fine.  So I'm 
not sure that what the fix was, the relabling or the rebooting 
immediately, but give it a try.

-- 
Knute Johnson
Molon Labe...



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]