[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: getting pine to run under fedora 0.94 -- a couple issues



On Tue, 7 Oct 2003, Jeremy Portzer wrote:

> Robert P. J. Day wrote:
> > 
> >   when i asked about this on another list, i'm sure i was pointed to a
> > filed bugzilla entry on this.  just now, i tried to query for this report,
> > but was utterly unable to find it.  i tried to be as general as possible,
> > "fedora", "test2", didn't even specify a status or anything. but got no
> > hits.
> > 
> >   can someone provide the magic incantation that would have produced this
> > bug report, based on the relevant keywords?  sometimes, bugzilla can be 
> > maddeningly non-productive.
> > 
> 
> I think you're referring to this:
> https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=101982
> 
> I found it by doing a quick search on "libcom_err.so.3" .  It was filed 
> on the "distribution" component which maybe is why you didn't find it. 
> I guess this is correct because it can't be a problem with pine, since 
> there is no pine in FC test2, but it's also not really a problem with 
> kerberos, since nothing else needs this.  Not sure how this can be resolved.
> 
> In answer to someone else's question on this thread about where to get 
> the SRPM, you can just use the one from Red Hat Linux 9, which is a 
> heavily patched version of 4.44.  Be sure to get the one from the 
> updates tree.  Also, you don't need to edit the spec manually, you can 
> just do this command on the SRPM:
> 	rpm --rebuild --define "nokerberos 1" pine-4.44-19.90.0.src.rpm
> 
> Of course, that disables kerberos which isn't approrpiate for everyone, 
> looks like the packages at Fedora.us solve that in a better way.

I managed to compile/install pine by obtaining
pine-4.58-1.9.0asp.src.rpm from rpmfind.net and modifying the spec file
as:

[balay dreamcast x]$ diff old/pine.spec new/pine.spec 
7c7
< Release: 1.9.0asp
---
> Release: 1.9.0asp.sb
128c128
< %{?!nokerberos: rm -f krb5 && mkdir krb5 && ln -s /usr/kerberos/include krb5/include && ln -s /usr/kerberos/%{_lib} krb5/lib}
---
> %{?!nokerberos: rm -f krb5 && mkdir krb5 && ln -s /usr/include/kerberos krb5/include && ln -s /usr/lib krb5/lib}
[balay dreamcast x]$ 

The only problem I have with this is - when using postfix as MTA (run
locally for sending mails via /usr/sbin/sendmail), pine just hangs. So
I use sendmail instead of postfix as the MTA.

Satish




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]