[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: system-config-display

It looks like when I run XFree86 as root, it drops its privileges for some reason.  If I copy the binary to root's home dir and take off the setuid bit, it runs fine and probes the card.  If I then copy the config file to /etc/X11 and restart the system, there are a bunch of "avc: denied" errors for XFree86.log in the syslog when gdm tries to start.  Anyone have any ideas?

-----Original Message-----
From:	fedora-test-list-bounces redhat com on behalf of Albert Wold
Sent:	Thu 4/1/2004 11:40 AM
To:	fedora-test-list redhat com
Subject:	system-config-display
I have a brand new system with an 865 video card (I think) and a Dell 19" flat panel.  When I installed, I don't remember seeing a section to configure X.  When I booted, it tried to start X several times and gave up.  After some digging, I found the system-config-display program and ran it.  It says this:

* ddcprobe returned bogus values:
ID: None
Name: None
HorizSync: None
VertSync: None

Trying with card: Intel 865
Error, cannot start X server.

So, apparently it doesn't work with this display.  I also tried XFree86 -configure which gives me an error saying "unable to locate/open config file: "/root/XF86Config.new"".  For now, I'm wondering if anyone knows of an alternate way to manually configure it.  I see that there is no xf86config command, which is what I used last time I had to do a manual X config.


fedora-test-list mailing list
fedora-test-list redhat com
To unsubscribe: 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]