[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Mozilla problem having gone to selinux



Paul wrote:
Hi,

Everything with the exception of one application seems to work since I
moved to selinux on the fc3t1 box.

I've done /sbin/fixfiles relabel and all seems okay.

However, if I run Mozilla, something odd happens.

I first off get asked to select a profile and if I select the default
user (the only one available), I get the error

Component returned failure code: 0x80004005 (NS_ERROR_FAILURE)
[nsIProfileInternal.currentProfile]

I can create a new profile, but that still returns the same error.

There is nothing wrong with Moz as such as if I mv .mozilla .moz and
restart, everything works as it should.

Any ideas on how to fix this one?

TTFN

Paul


I had this type of error when I transferred my profile from one system to another newly installed FC2 test version. It acted the same way as you described.


I had to created a fresh profile, then export the mail data into the newly created profile.

Does SELinux relabel .whatever directories to be SELinux enabled? Does mozilla set permissions a certain way, for files within the ~/.mozilla subdirectory, which conflict with what Mozilla requires?


No help, just experience a similar problem.


Jim

--
Logic doesn't apply to the real world.
		-- Marvin Minsky



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]