[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: No sound under the 2.6.1 test kernels



On Thu, 2004-02-05 at 06:51, Andy Green wrote:
On Thursday 05 February 2004 11:37, Bob Chiodini wrote:

> Also, updating the ALSA drivers in the 2.6 kernel does not hurt.

I read only yesterday that this was possible with the regular alsa-driver 
tarballs, but when I tried on the 2.6.1-1.65 I get

  CC [M]  /usr/src/alsa-driver-1.0.2/kbuild/../acore/memalloc.o
In file included from /usr/src/alsa-driver-1.0.2/acore/memalloc.inc:13,
                 from /usr/src/alsa-driver-1.0.2/acore/memalloc.c:1:
/usr/src/alsa-driver-1.0.2/include/adriver.h:425: error: conflicting types for 
`class_simple_device_add'
include/linux/device.h:255: error: previous declaration of 
`class_simple_device_add'
/usr/src/alsa-driver-1.0.2/include/adriver.h:426: error: conflicting types for 
`class_simple_device_remove'
include/linux/device.h:256: error: previous declaration of 
`class_simple_device_remove'
make[3]: *** [/usr/src/alsa-driver-1.0.2/kbuild/../acore/memalloc.o] Error 1
make[2]: *** [/usr/src/alsa-driver-1.0.2/kbuild/../acore] Error 2
make[1]: *** [/usr/src/alsa-driver-1.0.2/kbuild] Error 2
make[1]: Leaving directory `/lib/modules/2.6.1-1.65/build'
make: *** [compile] Error 2

Andy,

I tried the make with the stock 2.6.2 kernel (from kernel.org) without error.  The offending code:

/* sysfs */
#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 2)
struct class_simple;
static inline void class_simple_device_add(struct class_simple *class, int devnum, ...) { return; }
static inline void class_simple_device_remove(int devnum) { return; }
#endif

probably assumes kernel versions < 2.6.2 needs these definitions, but maybe Redhat has already brought their version of the kernel up to ALSA 1.0.2.  Try changing  KERNEL_VERSION(2, 6, 2) to KERNEL_VERSION(2, 6, 1) at line 423 in adriver.h.

Bob...
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]