[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: No sound under the 2.6.1 test kernels



On Fri, 2004-02-06 at 14:43, Andy Green wrote:

> The good news continued as I was able to modprobe the new snd-intel8x0 driver 
> into the kernel (after a make install of the alsa stuff), and it seems to 
> operate okay.  That's the native motherboard sounds system on this laptop 
> taken care of.
> 
> However when I tried to modprobe in the new usb-snd-audio, I get the following 
> complaint
> 
> [root fastcat alsa-driver-1.0.2]# modprobe snd-usb-audio
> FATAL: Error inserting snd_usb_audio 
> (/lib/modules/2.6.1-1.65/kernel/sound/usb/snd-usb-audio.ko): Unknown symbol 
> in module, or unknown parameter (see dmesg)
> [root fastcat alsa-driver-1.0.2]#
> 
> Here is the relevant part of /var/log/messages -- its a bit noisy with my 
> multiple attempts, but I left it as is in case it is meaningful
> 
> Feb  6 14:00:16 fastcat kernel: 
> ALSA /usr/src/alsa-driver-1.0.2/alsa-kernel/pci/ac97/ac97_codec.c:1858: MC'97 
> 1 converters and GPIO not ready (0xff00)
> Feb  6 14:00:16 fastcat kernel: intel8x0: clocking to 48000
> Feb  6 14:00:36 fastcat kernel: hub 1-0:1.0: new USB device on port 1, 
> assigned address 3
> Feb  6 14:00:36 fastcat kernel: input: USB HID v1.00 Device [Logitech Logitech 
> USB Headset] on usb-0000:00:1d.0-1
> Feb  6 14:00:37 fastcat modprobe: FATAL: Error inserting snd_usb_audio 
> (/lib/modules/2.6.1-1.65/kernel/sound/usb/snd-usb-audio.ko): Unknown symbol 
> in module, or unknown parameter (see dmesg)
> Feb  6 14:00:37 fastcat usb.agent[30013]: ... can't load module snd-usb-audio
> Feb  6 14:00:37 fastcat usb.agent[30013]: missing kernel or user mode driver 
> snd-usb-audio
> Feb  6 14:00:37 fastcat usb.agent[30024]: missing kernel or user mode driver 
> hid
> Feb  6 14:00:37 fastcat usb.agent[30018]: ... no modules for USB product 
> 46d/a01/6
> Feb  6 14:00:37 fastcat usb.agent[30023]: ... no modules for USB product 
> 46d/a01/6
> Feb  6 14:00:37 fastcat kernel: snd_usb_audio: Unknown symbol 
> usb_get_device_descriptor
> Feb  6 14:00:39 fastcat devlabel: devlabel service started/restarted
> Feb  6 14:00:39 fastcat devlabel: devlabel service started/restarted
> Feb  6 14:00:43 fastcat kernel: snd_usb_audio: Unknown symbol 
> usb_get_device_descriptor
> Feb  6 14:30:02 fastcat last message repeated 2 times
> Feb  6 14:32:37 fastcat kernel: snd_usb_audio: Unknown symbol 
> usb_get_device_descriptor
> Feb  6 14:39:11 fastcat kernel: snd_usb_audio: Unknown symbol 
> usb_get_device_descriptor
> 
> 
> I checked in an existing kernel module with strings, ide_cd.ko, it does not 
> have versioned kernel symbols and neither does the new snd-usb-audio.ko, so 
> that's not the problem.

usb_get_device_descriptor doesn't seem to get exported in the current
2.6 tree, and frankly I'm not sure if it should be. Greg ?

	Dave




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]