[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: No sound under the 2.6.1 test kernels



On Fri, 2004-02-06 at 09:43, Andy Green wrote:
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Friday 06 February 2004 13:38, Bob Chiodini wrote:
> On Fri, 2004-02-06 at 08:07, Dave Jones wrote:
> > On Fri, 2004-02-06 at 11:46, Bob Chiodini wrote:
> > > probably assumes kernel versions < 2.6.2 needs these definitions, but
> > > maybe Redhat has already brought their version of the kernel up to
> > > ALSA 1.0.2.
> >
> > No, we match upstream 2.6 exactly there.
> >
> > 	Dave
>
> Must be something ALSA is doing.  It wouldn't be the first time
> (schedule_work comes to mind).

Hi Bob -

Your idea about changing ./include/asound.h line 423 to read

#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 1)

did get it to compile, thanks very much.

The good news continued as I was able to modprobe the new snd-intel8x0 driver 
into the kernel (after a make install of the alsa stuff), and it seems to 
operate okay.  That's the native motherboard sounds system on this laptop 
taken care of.

However when I tried to modprobe in the new usb-snd-audio, I get the following 
complaint

Feb  6 14:00:43 fastcat kernel: snd_usb_audio: Unknown symbol 
usb_get_device_descriptor


I checked in an existing kernel module with strings, ide_cd.ko, it does not 
have versioned kernel symbols and neither does the new snd-usb-audio.ko, so 
that's not the problem.

Andy more ideas?

- -Andy
Andy,

I have never tried a USB sound device.  I grepped both the kernel (2.6.2) source and the ALSA source for usb_get_device_descriptor.  The references in the kernel indicate that it is not exported (you knew that!), and also takes a different argument list from the ALSA calls.  Grepping the 2.4.22-1.2115.nptl kernel source turned up the following (of interest):

drivers/usb/usb.c:int usb_get_device_descriptor(struct usb_device *dev)
drivers/usb/usb.c:      err = usb_get_device_descriptor(dev);
drivers/usb/usb.c:EXPORT_SYMBOL(usb_get_device_descriptor);

The ALSA driver for the USB sound device may not have been updated to support the 2.6 kernel.  It looks like the arguments match the call in the 1.0.2 ALSA source.  You might want to post a question to the ALSA folks.  Also check http://www.alsa-project.org/alsa-doc/doc-php/template.php?company=USB&card=Generic&chip=Generic&module=usb-audio
maybe something there may help (did not see anything though).

Bob...



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]